Table joins disappeared when importing .mxd to Pro

139
7
10-21-2019 10:01 AM
KatieErickson
New Contributor III

Recently switched over to ArcGIS Pro and when I imported my .mxd template, all of the table joins/relationships disappeared. Is there a way to correct this or will I have to manually re-join them?

0 Kudos
7 Replies
KoryKramer
Community Moderator

Are the related/joined tables in the map (as layers or table views)?  Or were the relates/joins just pointing to data sources?

0 Kudos
KatieErickson
New Contributor III

They are in the map as tables

0 Kudos
KatieErickson
New Contributor III

They are relates, so in the geodatabase

0 Kudos
VictoriaAnderson
Esri Contributor

Were these relationship classes or temporary relates on the map? If they are stored in the geodatabase as relationship classes, can you make a connection to the geodatabase in Pro and access them that way? 

Also, what version of ArcGIS Pro are you using and what version of ArcMap were your mxd's created with? 

0 Kudos
KatieErickson
New Contributor III

They are stored in the geodatabase...I connected to that database and the relationships seem to be working now, on one project (not on another - also with a connection). I pulled up the properties for the table in the non-working project and it shows the relationships, but when I click on a row and try to see the related tables through the table tab, nothing in there. Also see the relationships when pulling up the table properties through the geodatabase.

Using 2.4 Pro and Arcmap 10.6.

Could I remove them from the TOC and re-add into Pro from the gdb?  

0 Kudos
KatieErickson
New Contributor III

my mistake - the project that wasn't working doesn't actually have the tables in it  haha

0 Kudos
KatieErickson
New Contributor III

Ok, so now I am finding the tables themselves have the relationships but the polygon layer lost the link to the tables during the import. 

Some background info...

I have a polygon layer "Parcel" that connects to the "Parlink" table that connects to numerous other tables.

I can go from "Parlink" to "parcel" but not "parcel" to "parlink"

I created a new relate for "parcel" to "parlink" to get around this. I'm not sure this goes to the gdb level but is a solution for now