Security Alert Prompt with ArcGIS PRO 2.3.0

1580
10
Jump to solution
02-14-2019 12:19 PM
Lake_Worth_BeachAdmin
Regular Contributor

This only started occurring since the 2.3.0 upgrade.

Every time I open ArcGIS PRO I get the following pop-up alert.

is there a way to suppress this? 

0 Kudos
1 Solution

Accepted Solutions
Lake_Worth_BeachAdmin
Regular Contributor

I added the cert to the CA root cert store on my machine and the message went away.... 

View solution in original post

10 Replies
Robert_LeClair
Esri Frequent Contributor

Are you connecting to ArcGIS Online or Portal for ArcGIS under your Project->Portals options?

0 Kudos
Lake_Worth_BeachAdmin
Regular Contributor

ArcGIS Online

0 Kudos
Robert_LeClair
Esri Frequent Contributor

Interesting.  Do you have a Portal and/or Server up and running in your organization?  The reason I ask is the only information I found via Support Services is the following: 

"To resolve this issue, my recommendation would be to first determine whether you have a certificate that is valid and unexpired, and then to make sure that your Server has been supplied with the proper certificate(s) by following the workflow laid out at http://enterprise.arcgis.com/en/portal/latest/administer/windows/configuring-the-portal-to-trust-certificates-from-your-certifying-authority.htm"

Hope this helps but if not then I recommend a call to Esri Support Services at 888-377-4575

0 Kudos
MichaelVolz
Esteemed Contributor

Would a warning like this occur because ArcGIS Pro is designed by default to work with a portal such as AGOL?

If so, is there a configuration setting in Pro to disable this default behavior?

0 Kudos
JoshuaBixby
MVP Esteemed Contributor

in short, no, you can't just suppress the alert dialog.  Addressing the root cause is the best way to make the dialog go away.  If you click and view the certificate, what connection and specific issue is generating the alert?

0 Kudos
MichaelVolz
Esteemed Contributor

Joshua:

I was asking my question more about turning off Pro's apparent setting to go out to internet to get data from a portal.  My org has internet issues and starting up Pro nows takes 2 minutes to open even if the data is all stored internally, so I was looking to configure Pro not to try to connect to internet when it is opening.

0 Kudos
BillBott
Occasional Contributor

When Pro starts it checks for connectivity at each of the portals in the Pro portals list. After it starts up, go there and delete each entry you don't need by hovering the mouse over the entry and clicking the red X to the right.

If you are getting your license from ArcGIS Online, you won't be able to remove that connection from the list.

As for start-up taking 2 minutes - have you identified the bottleneck? Running everything on a capable but not ridiculous laptop here with the full stack installed (portal/server/pro) - Pro starts up in about 3 seconds.

Portal list

0 Kudos
Lake_Worth_BeachAdmin
Regular Contributor

the cert in question is for my GIS Server, which I have added to be added at startup to all new PRO projects.

issued by godaddy and its telling me the CA root certificate is not trusted. I installed it on my machine afterwards but the error still persists. 

0 Kudos
Lake_Worth_BeachAdmin
Regular Contributor

I added the cert to the CA root cert store on my machine and the message went away....