Rematch Addresses but no candidates

873
11
06-16-2021 07:56 AM
Labels (1)
BrianBulla
Regular Contributor

I'm trying to Geocode using ArcGIS Pro 2.8.  With my 'Tied' addresses is there a way to get the ties to show up in the candidates window??  For me, the candidates window is just blank:

BrianBulla_0-1623855250097.png

If I use ArcMap 10.4 to Geocode I do see the list of candidates shown:

BrianBulla_1-1623855354861.png

Am I missing a setting or something in ArcGIS Pro??

Thanks,

 

 

0 Kudos
11 Replies
JoeBorgione
MVP Esteemed Contributor

Interesting:  I'm getting something a bit different with my ties.  They show up matched to the same locator...

JoeBorgione_0-1623861610739.png

Seems like geocoding has become quite an adventure....

@ShanaBritt 

 

edited moments later:  it it turns out that the 51 ties matching to the same locator is because there are duplicate address points with the same address.  I inherited this data, so it's time for me to clean it up.  But it still begs the question as to why I'm getting ties to show up and op is not...

That should just about do it....
0 Kudos
MichaelVolz
Esteemed Contributor

It looks like you are using your own locator. Can you try using the World Geocoding Service on a small sample set to see if you get the same behavior (small set so as to not consume too many valuable credits)?

0 Kudos
BrianBulla
Regular Contributor

Whenever I try using the ArcGIS World Geocoding Service I get this error:

BrianBulla_0-1623863537628.png

 

Is this the correct URL??

https://geocode.arcgis.com/arcgis/rest/services/World/GeocodeServer/ArcGIS%20World%20Geocoding%20Ser...

 

0 Kudos
MichaelVolz
Esteemed Contributor

https://geocode.arcgis.com/arcgis/rest/services/World/GeocodeServer

The portion up to GeocodeServer looks correct, but you cannot access the REST endpoint as it is disabled for viewing.

The World Geocode Service should be available by default in the dropdown list for address locators when geocoding a table of addresses.

0 Kudos
BrianBulla
Regular Contributor

Hi @MichaelVolz ,

The World Geocode does not even appear as an option, yet is in my projects Locators folder. 

BrianBulla_0-1623935699400.png

 

BrianBulla_1-1623935760919.png

 

0 Kudos
MichaelVolz
Esteemed Contributor

What is your active portal (AGOL or on-premise)?  Do you have the World Geocoding Service referenced in the active portal?

I had AGOL as the active portal and the World Geoding Service was registered there so it appears by default.  I switched the active portal to an on-premise portal and the World Geoding Service was no longer available by default.  This might explain your scenario.

 

0 Kudos
BrianBulla
Regular Contributor

Hi @MichaelVolz 

My current portal for all of the above screenshots is:

BrianBulla_0-1623953520854.png

 

0 Kudos
ShanaBritt
Esri Regular Contributor

Brian:

1. Are you using the same locator in ArcMap that you are using in Pro?

2. What are the supported categories that are enabled in the locator properties of the Addr_Durham_Pro locator if it was created with the Create Locator tool?

3. I noticed that the candidates returned in ArcMap have an addr_type of Subaddress, but the input address is just <house number> + <street name> + <city>.  Are any candidates returned for '930 Byron Street, Town of Whitby' when enter in the Locate pane search box from your locator or the ArcGIS World Geocoding Service?

4. You would need to check that you have batch geocoding privileges in your organization to use ArcGIS World Geocoding Service, otherwise you would only be able to do geosearch or place finding (not batch). This would explain why you can see it and use it in the Locate pane, but not in any geocoding tools. 

0 Kudos
BrianBulla
Regular Contributor

Hi @ShanaBritt 

It's been ages since I've looked at this, but I'll try to answer your questions.

1.  Yes, I was using the same locator in both Pro and ArcMap

2.  I have no idea.  I created the ADDR_Durham_Pro ages ago.  Is there a way to backtrack and find out?

3.  No.  930 Byron Street will not geocode, since there needs to be a N or S distinction.

4.  I most likely do not have that privelege, so probably why it's not working.

 

0 Kudos