Project Package Failure in Pro

1041
6
11-12-2020 01:43 PM
Labels (1)
Alena
by
New Contributor III

I'm using ArcGIS Pro 2.6. I keep getting a failure when I try to use Project Package. Map Package works for me. Any suggestions? Is there something I'm forgetting to do?

C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:28 Status: InProgress StatusMessage: Successfully wrote sharing info file
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:28 Status: InProgress StatusMessage: Creating thumbnail from map
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:28 Status: InProgress StatusMessage: About to start the external packaging process
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:28 Status: Pending StatusMessage: Sharing process started
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:31 Status: InProgress StatusMessage: Sharing process started
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:31 Status: InProgress StatusMessage: Successfully obtained a license from the licensing portal
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:31 Status: InProgress StatusMessage: Reading thumbnail from file
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:31 Status: InProgress StatusMessage: Packaging in progress
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:31 Status: InProgress StatusMessage: Creating a project package and saving it locally
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:31 Status: InProgress StatusMessage: Compiling packaging parameters
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:31 Status: InProgress StatusMessage: Initiating the packager
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:26:31 Status: InProgress StatusMessage: The project package tool has started
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:29:06 Status: Failed ErrorMessage: General function failure
C:\workspace2\cache\test_package_20201112.ppkx 98 ProjectPackage 2020-11-12 16:29:08 Status: Failed ErrorMessage: Failed to package.

Thanks!

Alena

Tags (2)
0 Kudos
6 Replies
JonahLay
Esri Contributor

Hi Alena,

Can you try using the Package Project geoprocessing tool to see if that works?

Thanks,

Jonah

0 Kudos
Alena
by
New Contributor III

It still fails.

ERROR 999999: Something unexpected caused the tool to fail. Contact Esri Technical Support (http://esriurl.com/support) to Report a Bug, and refer to the error help for potential solutions or workarounds.
Failed to execute (PackageProject).

I just have a shapefile in the map, just to see if it would work. I've tried to keep it as simple as possible and not include any toolboxes or history. 

0 Kudos
JonahLay
Esri Contributor

Hi Alena,

I wasn't able to reproduce a packaging failure with a shapefile in my project at 2.6. I suggest contacting Esri Technical Support for best assistance. They should be able to take a closer look into the issue.

Best,

Jonah

0 Kudos
by Anonymous User
Not applicable

Is there an active join on any of the layers in the Project?

0 Kudos
Alena
by
New Contributor III

No, there is no active join. I've kept it as simple as possible, just trying to get it to work. 

0 Kudos
DavidMurray_ODWC
New Contributor III

I had been running into the same problem.  Tool is still running now, in fact, but it is well past the point where it has failed over and over again.  Error started out exactly as OP's; I altered Package Project tool parameters little by little until I seemed to make progress.  My solution ended up being to delete all my custom models in the project toolbox.

0 Kudos