Problem with empty geodatabase when moving projects between computers

504
5
09-06-2021 12:13 PM
StephenMech
New Contributor II

I have an issue grading student projects. To verify they have built their project correctly, I have them submit a zipped copy of their complete folder including the geodatabase, aprx, etc. This was my standard practice Prior to ArcGIS PRO 2.6. However, now that we have upgraded to ArcGIS Pro 2.8, when I open the project on my computer the links to the data are broken, even though the geodatabase link in the catalog points to the correct location.

StephenMech_0-1630955338636.png

 

The geodatabase appears empty until I navigate to the actual location (rather than the link found in the project). This is interesting given that it really is the same geodatabase.

StephenMech_1-1630955364535.pngStephenMech_2-1630955372414.png

 

Can anyone explain to me how I can fix this short of having the students make map packages and/or me accessing their individual computers? 

0 Kudos
5 Replies
David_Brooks
MVP Regular Contributor

@StephenMech , yes i have noticed the same thing.

If you right mouse click on the database in the Databases folder, and select Properties. Whats the path in the "name" field? Does that match the correct location?

Brooks_SummitGeo_0-1630960898550.png

Also, Im assuming the FGDB your students are providing is in the same folder as the APRX when your students work on the project? And that you then locate the FGDB and APRX in the same folder when you open the project? 


David
..Maps with no limits..
0 Kudos
StephenMech
New Contributor II

@David_Brooks  Yes, the directory is accurate (the first image was intended to show this). 

Interestingly, the problem is not consistent: some student's files work fine, but others don't.

@DanPatterson I may use the package option, but this has not been an issue in the past, so I'm not sure why it is now...

0 Kudos
DanPatterson
MVP Esteemed Contributor

Can't pinpoint the date right now, but toolboxes began to be handled differently circa Pro 2.7 and there were other behind the scenes changes... don't know exactly what would be a definitive cause but taking up a case with Tech Support might be prudent... anything to simplify the assessment and marking 😉


... sort of retired...
0 Kudos
StephenMech
New Contributor II

I'll start a case and see what they say.

0 Kudos
DanPatterson
MVP Esteemed Contributor

Before term begins, you might want to consider using

Package Project (Data Management)—ArcGIS Pro | Documentation

See if moving it from machine to machine and/or folder will enable you to identify any particular issues.


... sort of retired...
0 Kudos