Pop-Ups from Pro to Online

80
1
06-26-2019 07:14 AM
Highlighted
Frequent Contributor II

it had been my understanding that one of the benefit's of Pro was to be able to design your Feature Layers in Pro and publish them direct to Online/Portal etc.  And they should look the same.

For the most part this is true.  However, I order the fields in Pro the way I want them to look online. I configure popups to have on and off what I want on and off.

However, the publish is not respecting the order.  I have two fields that the crews wanted moved up 3 levels and given a new Alias.  I moved them up three levels and<share><Overwrite Web Layer> .  When I open the feature service online they are back where they started, but the Alias names are correct.

Do I need to delete the existing Feature Layer and publish it new?  Which I really want to avoid so I don't have to take down those services.

Any idea what I am doing wrong?   I really would like to avoid having to go into the Feature Layer every time I make a change and have to re-do the Pop-Ups

1 Reply
Highlighted
New Contributor III

I have a similar problem, in that I have configured a popup in Arc Pro (current version 2.4.3) using a complex Arcade expression that translates codes to descriptions, and shared this layer as a Feature Service to my ArcGIS Server. The feature service is being passed along to my Arc Online account, like everything else in my Arc Server installation, but not the configured popup (Arc Online defaults to an "all fields" popup).

Reply
0 Kudos