Number formatted to percent doesn't stay

241
3
Jump to solution
12-01-2021 07:33 AM
Labels (3)
SSMGroup
Occasional Contributor

I'm updating a shapefile in ArcPro.  I have a series of Double fields that represent a percentage.  (ie. 3.2 = 3.2%)

Because I want the number to display as a percent, I open the fields view and change the Number Format to "Percentage."

I save my changes, they save successfully and I see the changes.

But then after doing some joins and other process on the data, I lose my Field Alias and the Number Format I set.  Why doesn't it stay?

0 Kudos
1 Solution

Accepted Solutions
SSMGroup
Occasional Contributor

Is there documentation somewhere about this? I was wondering if that was a limitation but couldn't find documentation on it. Unfortunately I'm delivering this to a client who wants the data as a shapefile.

I've tried it in ArcPro and ArcMap.  I'm on the phone with technical support now, and it reproducible every time for me.  

It always reverts back to the field name (instead of the alias) and numeric formatting (instead of percentage formatting) after I remove a join. 

 

 

Update: This issue has now been submitted as a bug.

  1. Bug number: BUG-000144940
  2. Synopsis: Alias name and Number Format revert to default after remove join ArcGIS Pro

View solution in original post

0 Kudos
3 Replies
DanPatterson
MVP Esteemed Contributor

copy the shapefile to a featureclass in a geodatabase and try that.  I suspect that shapefiles, because of their limitations, may not support all the properties that a geodatabase can manage


... sort of retired...
SSMGroup
Occasional Contributor

Is there documentation somewhere about this? I was wondering if that was a limitation but couldn't find documentation on it. Unfortunately I'm delivering this to a client who wants the data as a shapefile.

I've tried it in ArcPro and ArcMap.  I'm on the phone with technical support now, and it reproducible every time for me.  

It always reverts back to the field name (instead of the alias) and numeric formatting (instead of percentage formatting) after I remove a join. 

 

 

Update: This issue has now been submitted as a bug.

  1. Bug number: BUG-000144940
  2. Synopsis: Alias name and Number Format revert to default after remove join ArcGIS Pro
0 Kudos
SSMGroup
Occasional Contributor

Update: this issue was marked as a bug.  

0 Kudos