My Content Empty When Trying to Overwrite Web Layer

308
1
Jump to solution
12-17-2020 09:45 AM
Labels (1)
MollyFoley
Regular Contributor

I'm working in Pro and I am trying to overwrite a web layer that currently exists on my AGOL account. It is hosted by our server and is not hosted by AGOL. I am logged into my account when in Pro and if I go to Catalog > Portal > My Content, all my map and feature services appear here. The layer I want to overwrite is included in this window, however when I go to Share > Overwrite Web Layer and the new dialog window appears, it shows nothing in My Content. How do you fix this?

To better illustrate what I'm saying, this is my Catalog pane:

Capture.JPG

 

This is the dialog box when I try to overwrite a web layer:Capture1.JPG

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
MollyFoley
Regular Contributor

Wish I could delete questions on the new Geonet but I can't, so I'll just post my "answer" (e.g. my stupidity) anyway. 

I think I was confusing "Web Layer" with "Feature Layer" (aka feature service) maybe? I'm still not clear on if it's a terminology difference or they are actually two different things. Regardless, I was trying to overwrite a feature service because when you publish a map service, the feature service gets published up too - the web layer and feature layer icons for AGOL look very similar so I was getting caught up in that in the Catalog > Portal > My Content pane. What I should have been doing was overwriting the map service. To do this I went to the Catalog Pane, expanded my server down to the map service I wanted to overwrite and then right-clicked it and hit "Overwrite."

View solution in original post

0 Kudos
1 Reply
MollyFoley
Regular Contributor

Wish I could delete questions on the new Geonet but I can't, so I'll just post my "answer" (e.g. my stupidity) anyway. 

I think I was confusing "Web Layer" with "Feature Layer" (aka feature service) maybe? I'm still not clear on if it's a terminology difference or they are actually two different things. Regardless, I was trying to overwrite a feature service because when you publish a map service, the feature service gets published up too - the web layer and feature layer icons for AGOL look very similar so I was getting caught up in that in the Catalog > Portal > My Content pane. What I should have been doing was overwriting the map service. To do this I went to the Catalog Pane, expanded my server down to the map service I wanted to overwrite and then right-clicked it and hit "Overwrite."

View solution in original post

0 Kudos