How to set Transparency in the Legend in Pro

6262
8
Jump to solution
08-19-2015 09:43 AM
SonaSunny
Occasional Contributor

I have set a transparency to my layer in the map but that transparency is not being reflected in the legend. In ArcMap you could set that but don't know where that option is in Pro. Any help will be appreciated.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
KirstenPinkston
Esri Contributor

Hi Sona,

Thanks for your post. No such option exists in Pro, because once transparency is applied to a layer's symbology in a map, this should be automatically reflected in the legend. Here is an example.

Is the map that you're updating, the same as the map frame in your Layout? There are a couple way's to check this:

In Layout view, right-click the map frame and go to Properties. On the Element pane under Options > General look to see that the Name is the map name + Map Frame:

Or, if you right-click the map frame in Layout view and choose Activate to activate the map, go to the Contents pane and right-click your layer symbol > Color Properties, and change the transparency. Once transparency is applied, click the Layout tab > close activation. Observe the Legend-- does it reflect this change in transparency? If so, its likely that the map you were updating originally is not the same as the map in your Layout.

I hope this is helpful. If you continue to see issues with the updating of legends, let us know and we'll continue to investigate.

Thanks,

Kirsten

View solution in original post

8 Replies
SonaSunny
Occasional Contributor

Capture1.PNGwhere is this option in pro??

0 Kudos
KirstenPinkston
Esri Contributor

Hi Sona,

Thanks for your post. No such option exists in Pro, because once transparency is applied to a layer's symbology in a map, this should be automatically reflected in the legend. Here is an example.

Is the map that you're updating, the same as the map frame in your Layout? There are a couple way's to check this:

In Layout view, right-click the map frame and go to Properties. On the Element pane under Options > General look to see that the Name is the map name + Map Frame:

Or, if you right-click the map frame in Layout view and choose Activate to activate the map, go to the Contents pane and right-click your layer symbol > Color Properties, and change the transparency. Once transparency is applied, click the Layout tab > close activation. Observe the Legend-- does it reflect this change in transparency? If so, its likely that the map you were updating originally is not the same as the map in your Layout.

I hope this is helpful. If you continue to see issues with the updating of legends, let us know and we'll continue to investigate.

Thanks,

Kirsten

SonaSunny
Occasional Contributor

Kirsten,

Thank you for your quick response! This is how my layout looks.I have only this one map in this project. It was a layout that i imported from a previous project.

Capture2.PNG

0 Kudos
KirstenPinkston
Esri Contributor

Thanks for the screen shot Sona. Happy to help. So, I tested with the import workflow to see if I could reproduce the issue with an existing Layout, but I don't have any trouble seeing updates in the legend when I change transparency for layer symbols in my map.

If you turn your legend on and off in the Contents Pane, do you see any change? Also, are any of the Beats symbols updating in the Legend when you apply transparency?

0 Kudos
SonaSunny
Occasional Contributor

Kirsten,

It worked when i followed the following method that you had suggested!!. Thanks for your help!

"- right-click the map frame in Layout view and choose Activate to activate the map, go to the Contents pane and right-click your layer symbol > Color Properties, and change the transparency."

The transparency dint change in the legend  when i set the transparency in the Appearance tab.

Capture1.PNG

Uwera
by
New Contributor

The method did not work for me. I found a work arround instead. Converting the legend to graphics before applying transparency to the layer.

0 Kudos
JuliaBalakirova1
New Contributor III

Hello.

The "offered" solution in this post is only partially  a solution as it is based on the assumption that transparency is automatically applied from the layer to the legend when applied via "Appearance" tab.

I just ran into this issue with 2.7 version of Pro. My transparency is driven by an attribute value. In this case, the legend did not take transparency of the layer. When I tried to apply transparency to the whole layer from "Appearance" (instead of using attribute field value assigned to each individual polygon), the legend took change and applied transparency. So, the legend does not display transparency if used by an attribute value.

In the ArcMap, having checkbox checked in the property of the layout would work for both scenarios. At the moment I am assuming this is a shorting in Pro since it is still relatively new software.

Is it possible to fix this glitch in the future releases?

 

 

 

 

0 Kudos
JosephWilbur
New Contributor

To set transparency for legend background:

- Navigate to legend properties

- Click on display tab (dotted cube with paintbrush inside)

- Click on background symbol dropdown

- Click on color properties at bottom (opens color editor)

- Adjust transparency with the slider

0 Kudos