How do I remove the 180th meridian line on my map of Russia?

3312
26
Jump to solution
03-18-2019 10:18 AM
JOSHUALOGSDON
New Contributor III

I'm not sure how to remove the line that represents the 180th meridian (international dateline) on my polygon. I have the "Russia Country Boundary 2017" feature layer added from the Living Atlas. My Projected Coordinate System is set to "Asia North Albers Equal Area Conic". I've tried to google this question, but I haven't come across an answer I can fully understand. I'm a student and very new to all this!

Thank you!

The line is actually a gap between the polygons.

Russia polygon with 180th meridian line

Using ArcGIS Pro 2.3.1

ANSWER:

Thanks to everyone below, it turns out I was not projecting correctly, which was creating issues down the line when editing polygons. Here's what I did...

  1. Start a blank project in ArcGIS. Insert new map, go into its properties, change the Coordinate System to "Asia North Albers Equal Area Conic".
  2. Add "World Countries (Generalized)" from the Living Atlas. Select Russia and Export Features to new feature class layer.
  3. Search and select the Project tool from Analysis>Geoprocessing>Tools.
  4. Select the Russia layer for input. Select "Current Map" for Output Coordinate System. Run.
  5. Now edit the polygons to close the gap and merge to remove any lines. All done!

Hope this helps. The only thing that bothers me with this fix is the addition of shape area (484,914.49674 m²) and shape length (4.59 m) to the original Russia polygon. These numbers could be different depending on how you close the gap, and possibly affect data projections depending on your use of this map? IDK, but thank you everyone who helped get us this far!

1 Solution

Accepted Solutions
MelitaKennedy
Esri Notable Contributor

Joshua, what coordinate system is the copy of the Living Atlas data using? Is it using the Asia North Albers definition? If it isn't and is instead using a geographic coordinate system like WGS84, GCS is native stored with longitudes between -180 and +180. Any edit will get clipped at the line, even if you're projecting the data on-the-fly to another coordinate system where the "180" line is interior to the extent of the coordinate system. 

If you create a dataset using the Asia North Albers coordinate system, and edit in the coordinate system, there shouldn't be a problem with merging.

View solution in original post

26 Replies
DanPatterson_Retired
MVP Esteemed Contributor

did you just try changing the border color and/or size for the symbology?

JOSHUALOGSDON
New Contributor III

Well, I'd like to make it white fill with black outline for the end result. Line still appears.

0 Kudos
by Anonymous User
Not applicable

Dan is correct and you might want to change color of the boundary for the polygons to match what color the inside of the polygon is...that will mask the extra boundary line.

JOSHUALOGSDON
New Contributor III

I would like the end result to be white fill and black outline Russia. I'm not sure if his solution will work for that.

0 Kudos
PLS_KateGladstein
New Contributor III

Hello Joshua - no problem. Open the attribute table, select all polygon records of russia (it appears you have at least 2), and run the Merge geoprocessing tool.

JacobTaylor3
New Contributor III

I also thought this would solve his problem, but I looked at the image again and it appears that that his image also includes his attribute table at the bottom. There's only one feature in his attribute table. I had a similar problem that I wasn't able to solve on a map of the United Kingdom. I assumed mine had something to do with the style I was using. The fact that he only has one feature makes it unlikely to be fixed by changing border colors as well and his map seems be the base style, so while I don't have a solution, I do wonder why this is the case.

MatthewDriscoll
MVP Regular Contributor

Did you try and explode it?

PLS_KateGladstein
New Contributor III

You are very right Jacob, I did not notice that.

Joshua, I tried a couple ideas I assumed would work, but you were right, this is more tricky.

There is a good solution below for solving your issue in ArcCatalog/Desktop, but I wanted to see if I could fix this in Pro.

Here's what I did which finally worked.

I did find a much more accurate country boundary - Russia North Regions - still had the international date line digitized.

   1. I went into Map Properties, made sure it was WGS 1984, and checked the box that says "Enable wrapping around the date line".

   2. Because this dataset is separated into states, I first dissolved into one boundary.

I opened the attribute table, added a field called "country", right click the column, calculate field, country = "Russia"

   3. Dissolve GP tool. Dissolve on new "countries" field

Yay, now one polygon. But with same dateline issue.

   4. Edit toolbar, modify features pane, delete the verticies demarcating the date line.

Then reconnect the nearby verticies with each other.

Side project of the morning complete

JOSHUALOGSDON
New Contributor III

So I'm trying to connect the vertices in a few ways, but I'm getting several errors. When I try to draw a polygon over the 180th meridian to fill the gap, I either get split polygons split polygonsor polygons that fill the entirety of the map.

fill map

I can't seem to draw over the meridian at all.

How exactly would I connect these vertices?

Vertices

0 Kudos