Failed to publish hosted feature layer to ArcGIS Enterprise from ArcGIS Pro

752
4
03-23-2022 04:29 AM
MohammedAlhessi4
New Contributor

Hello,

I have a problem of publishing hosted feature layer from ArcGIS Pro to our Portal on ArcGIS Enterprise.

The steps I used is shown in the following screen:

MohammedAlhessi4_0-1648034640612.png

 

The error I got is here:

MohammedAlhessi4_1-1648034784442.png

 

The error is:

"Server Response: ERROR: code:403, User does not have permissions to access 'hosted/served_health_facilities.mapserver'., Access to this resource is forbidden, regardless of authorization."

Knowing that I publish a feature class that is in relation with another table through relationship class in the project Geodatabase as shown in the first screen.

 

I highly appreciate your support on this issue very soon, since I have to meet the deadline.

Have a nice day!

0 Kudos
4 Replies
sxw_eaglegis
Esri Contributor

Hi Mohammed, a few questions about this - Is there already a map service published to your ArcGIS Enterprise site called "served_health_facilities"? What type of authentication does your portal use? is it built-in users? and I guess your user has publisher rights?

0 Kudos
MohammedAlhessi4
New Contributor

Thank you @sxw_eaglegis  for your response. Let me answer you questions as follows:

Is there already a map service published to your ArcGIS Enterprise site called "served_health_facilities"?

I have searched My content, but there is no one with the same name.

What type of authentication does your portal use?

I am not the administrator of my account, but I can conclude it is Active Directory Authentication because I use the same way and the same login credentials when I log into other applications.

is it built-in users?

I didn't understand this.

and I guess your user has publisher rights?

Yes I am creator with Publisher role.

I would like to confirm that the problem is when I publish the feature class with its related table. If there is no relationship class in the geodatabase, It works without any problems.

 

 

0 Kudos
dhowes1
New Contributor II

I am having an identical issue.  Was a resolution found?

0 Kudos
laubert
New Contributor

I am having this issue as well. 

StatusMessage: Server Response: ERROR: code:403, User does not have permissions to access 'hosted/cable.mapserver'., Access to this resource is forbidden, regardless of authorization.

0 Kudos