Exported feature class not showing up in .gdb in Catalog view in ArcGIS Pro

205
2
Jump to solution
a week ago
Labels (1)
SarahBlake
New Contributor II

As a college GIS instructor, I am learning ArcGIS Pro, so I can teach my students in the near future, and  utilizing the "Mastering ArcGIS Pro" textbook by Maribeth Price.  In the chapter 5 tutorial, I'm finding that my exported feature classes (I've either done a 'select by attributes' or a 'clip' first) are not showing up in the Catalog view, within the project geodatabase that they are in. The layers show up fine within the map, and I have tried 'refresh' and 'save' and even tinkering with the indexing options (earlier had issues with thumbnails not appearing), but to no avail.  Only closing the program and then re-opening it seems to work in order to then see the newest feature classes I've added to my .gdb.  A glitch? Or some setting I'm missing?

Thanks,

Sarah

0 Kudos
1 Solution

Accepted Solutions
MatthewBrown8
Esri Contributor

Hi @SarahBlake,

The behavior you have described does occur occasionally, whereby the data will not immediately appear in the expected location. As you have identified, the solution to this is to navigate to the Databases folder within the Catalog pane, right click on the .gdb and select Refresh. 

MatthewBrown8_0-1623211125479.png

Regards,

Matthew

View solution in original post

0 Kudos
2 Replies
SarahBlake
New Contributor II

Aah - I may be answering my own question...I didn't realize there is a separate 'Refresh' button in the Catalog tab, Organize group...I had been using the 'Refresh' when in the map view.  I just tested the process doing another export to my project.gdb, then the correct 'Refresh' and there it was!

SB

0 Kudos
MatthewBrown8
Esri Contributor

Hi @SarahBlake,

The behavior you have described does occur occasionally, whereby the data will not immediately appear in the expected location. As you have identified, the solution to this is to navigate to the Databases folder within the Catalog pane, right click on the .gdb and select Refresh. 

MatthewBrown8_0-1623211125479.png

Regards,

Matthew

View solution in original post

0 Kudos