Select to view content in your preferred language

Duplicate bar diagrams appearing in ArcGIS Pro layout when exporting map: how to prevent and resolve the issue?

1256
2
Jump to solution
04-07-2023 11:27 PM
RadhakrishnanThulasi
New Contributor II

How can I prevent duplicate bar diagrams from appearing in my ArcGIS Pro layout when exporting a map? Specifically, when exporting at 600dpi, I'm seeing 2 to 3 identical bar diagrams instead of just one. Any suggestions on what may be causing this issue and how to fix it?Layout view mapLayout view mapExported map with 600dpiExported map with 600dpi

0 Kudos
1 Solution

Accepted Solutions
RadhakrishnanThulasi
New Contributor II

Great news!

I found the solution to the question raised by me.

Turning off the "Prevent chart overlap" option in the symbology settings should prevent the duplication of bar diagrams when exporting the map.

For those who may be experiencing a similar issue, here are the steps to disable "Prevent chart overlap" in ArcGIS Pro:

  1. Go to the "Map View" tab in ArcGIS Pro and choose the feature layer you want to adjust.

  2. Click on the "Symbology" tab in the "Contents" pane.

  3. Under "Charts", click on the "Leader Lines" drop-down menu.

  4. Uncheck the box next to "Prevent chart overlap".

  5. Save your changes and try exporting the map with the bar diagram again.

This should prevent the duplicate bar diagrams from appearing in the exported map.

Thanks.

View solution in original post

2 Replies
RadhakrishnanThulasi
New Contributor II

Great news!

I found the solution to the question raised by me.

Turning off the "Prevent chart overlap" option in the symbology settings should prevent the duplication of bar diagrams when exporting the map.

For those who may be experiencing a similar issue, here are the steps to disable "Prevent chart overlap" in ArcGIS Pro:

  1. Go to the "Map View" tab in ArcGIS Pro and choose the feature layer you want to adjust.

  2. Click on the "Symbology" tab in the "Contents" pane.

  3. Under "Charts", click on the "Leader Lines" drop-down menu.

  4. Uncheck the box next to "Prevent chart overlap".

  5. Save your changes and try exporting the map with the bar diagram again.

This should prevent the duplicate bar diagrams from appearing in the exported map.

Thanks.

Cmil137
New Contributor

Hi! I am also having this problem, but I cannot turn off the 'prevent chart overlap' option otherwise all my charts are illegible and grouped overtop of one another. Any advice on how to prevent chart duplication when exporting in JPEG (or PNG) would be hugely appreciated. 

0 Kudos