Colour of TIN does not match legend

482
12
Jump to solution
11-09-2021 08:04 AM
cpenling
New Contributor II

Does anyone else have this issue with colour palette's on TIN's? As you can see in the picture, the legend colours don't match the TIN colours. The TIN is contained within the blue line surrounding the lake. I wanted the shallowest area to match the colour of the lakes outside that line (without bathymetry) but the same colour has a grey tint to it when applied to the TIN. This doesn't matter too much because I could make the shallowest depth invisible and just correct it in the legend after. But the problem is none of the colours in the legend match the TIN. I'm using ArcGIS Pro 2.8.0. 

0 Kudos
12 Replies
cpenling
New Contributor II

My work around for this issue was to convert the TIN into a raster and then create a hillshade from the raster. Turn on transparency for the raster, underlaid the hillshade and then play around with the colours until they match. The colours on the legend match the raster/hillshade colours much better then the TIN at the very least. 

0 Kudos
JeremyWright
Esri Regular Contributor

This difference appears to be due to the lighting applied to the TIN.

In Pro, the TIN is always "lit" (based on illumination settings in Map Properties).

In ArcMap, you could choose to turn this feature on and off from the Symbology tab of Layer Properties (it's called "show hillshade illumination effect in 2d display").

The mismatch you are seeing is a result of this lighting effect being applied to the TIN based on each face's aspect/angle to light - simulating how it would appear if drawn in 3d.  This shading can be helpful to recognize the orientation of the different faces of the TIN dataset, much the same way a hillshade helps understand the shape of a DEM.

There's no way to make it match identically to the legend depending on whether one classification of elevation faces multiple directions if the lighting will result in some faces being in "shadow" and some being "in the light".

If you want the least difference, you can change lighting to move the altitude to 90 degrees, that means the light is coming from straight up, so no shading should be applied.  By default it is set to 30 degrees elevation in Map Properties->Illumination.

cpenling
New Contributor II

Thanks so much for the explanation. Makes sense! Changing the altitude to 90 degrees didn't really work for me because it got rid of the that 3d effect which I wanted to maintain on the bathymetry. It basically just looked like a flat raster surface. Put I set it at around 50-60 then darkened the water layer to match. It still has a bit of a 3d effect but the colours match better. Basically the same results I got with creating a separate hill shade but less steps! It would be great if you could pick the undertone of the hill shade in a TIN surface. 

0 Kudos