Select to view content in your preferred language

Can't reorder legend items (not locked)

2416
10
05-16-2022 07:16 AM
Labels (1)
NeilCurriVC
New Contributor III

Hello. I keep running into this issue, usually after duplicating a layout, where I can no long reorder the legend items in the duplicated layouts. The legend is NOT locked. I can move the reorder items in the legend of the original layout, but I cannot in the duplicated layouts . The mouse curser simply changes to the circle/slash symbol when I try to move any one of the items below or above any of the other items. Anyone else encounter this? 

Tags (3)
10 Replies
AubriKinghorn
Esri Regular Contributor

Hi,

I can't reproduce this problem with my own data in 2.9. Can you tell me more about what you are seeing? Is the Layer order option checked for your legend? It might also be worth reaching out to Technical Support to report this bug as they have a great resources and can get the issue to the right team to address.

Cheers,
Aubri
NeilCurriVC
New Contributor III

Don't know how I can describe it in any more detail except to make a video. Thanks for responding, though. I will create a support case as you suggested. Someone else has posted on this thread now with the same problem, so it's apparently a thing, and at least those who are experiencing it know what I'm trying to describe.  

0 Kudos
AdamBowen
New Contributor III

Did you ever get a response from support? I'm still experiencing this.

0 Kudos
NeilCurriVC
New Contributor III

I never followed up on this but will when I next encounter it. I can't remember the project that was giving me the problem and I need to reproduce it for Esri support. Sometimes it's just quicker and easier to do the workaround than to go through a support case. 

0 Kudos
AdamBowen
New Contributor III

I feel kind of dumb for this. This may not be your issue, but I realized in a template I have been using, a toggle called "Layer Order" was enabled just like AubriKinghorn mentioned. This was preventing me from reorganizing the list. Not sure why it was toggled in the first place.

Fingers crossed this is also your issue. Good luck!

0 Kudos
AdamBowen
New Contributor III

Same problem on my end. I am using the same imported template I've been using daily for the past two years and I haven't had this issue before.  I wish I could provide more input, but I'm not doing anything different from what I normally do.

0 Kudos
LeighMercer17
New Contributor

Hi, I ran into this same problem today. My issue was some of my layers needed their data source repaired, and that was preventing me from reordering my legend items. Afterwards I was able to reorder no problem. Hope this helps if you are in the same situation.

0 Kudos
CourtneyCameron
New Contributor

I ran into this as well and realized that I had to be List By Drawing Order. I was in List By Element Type and it wouldn't let me move anything around.

Cavaletta
New Contributor

Hi there, appreciate that this is quite an old thread now, however I had the same problem today where I couldn't rearrange legend items.  The solution in this case was to turn this setting OFF from within the legend properties.

Cavaletta_0-1710185228918.png

Hope that might help someone who stumbles across this in search of a fix.
Credit goes to my colleague who had to help me find that setting!