ArcMap vs. ArcGIS Pro Tile Cache Creation

150
1
Jump to solution
08-06-2019 06:03 AM
Highlighted
Occasional Contributor III

I am currently migrating to ArcGIS Pro and I have a question regarding tile cache creation.

In ArcMap, I previously created tile caches by publishing a service and specify how I want to create the tiles through the Caching tab in the Service Editor box right before I publish it.

In ArcGIS Pro, I no longer have those options from the publishing dialog box. Instead, I publish it as a map service, then use the Create Map Server Cache and Manage Map Server Cache Tiles tools to create the tile cache.

The one issue I am running into in ArcGIS Pro is that tile cache creation is significantly slower. In ArcMap, the server cache creation would utilize all of the available instances in the CachingTools geoprocessing service. In ArcGIS Pro, it tells me that 0 instances are running, yet it is still creating the tile cache. In the Manage Map Server Cache Tiles tool parameters, it asks for the number of caching service instances. I've tried setting it to -1 (the default) as well as other numbers, but the CachingTools geoprocessing service always says 0 instances are in use (and only one instance of the CachingControllers in use).

How can I get the tool to utilize all of the available instances? I went from 6 hours creation time in ArcMap to over 2-3 days in ArcGIS Pro.

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Occasional Contributor III

I contacted Esri support and it turns out this is a bug. The tool in ArcGIS Pro works if the map service was originally published in ArcMap.

But if the map service was originally published from ArcGIS Pro, then the tool does not honor the number of caching service instances specified in the tool.

The bug number is: BUG-000109510

View solution in original post

1 Reply
Highlighted
Occasional Contributor III

I contacted Esri support and it turns out this is a bug. The tool in ArcGIS Pro works if the map service was originally published in ArcMap.

But if the map service was originally published from ArcGIS Pro, then the tool does not honor the number of caching service instances specified in the tool.

The bug number is: BUG-000109510

View solution in original post