ArcGIS Pro not sorting numeric attributes correctly

248
5
12-27-2021 06:33 AM
Labels (1)
LeilaJackson1
Occasional Contributor

I am encountering issues with ArcGIS Pro (2.8.1) not sorting numeric attributes correctly as shown below when Urgency_CR is sorted ascending (see snapshots 1 and 2 below). When I use the custom sort, and select ascending it sorts correctly. On further investigation, it appears that Pro is sorting on the attribute to the right of the attribute I am trying to sort on. For example in the 3rd snapshot below, I tried to sort on RoadwayElevation Ascending using the drop down and it did not work. When I opened the Custom Sort window it showed the attribute to the right being sorted (I had not previously sorted on that attribute).

I have  also had an issue where I was not able to sort an attribute (ascending and descending were shaded out in the dropdown menu), but I was able to sort using custom sort.

LeilaJackson1_0-1640198496588.png

LeilaJackson1_2-1640198563374.png

 

LeilaJackson1_0-1640615296911.png

 

 

Tags (2)
0 Kudos
5 Replies
ABishop
Regular Contributor III

What field type are those fields you are sorting?

Amanda Bishop, GISP
0 Kudos
LeilaJackson1
Occasional Contributor

Urgency_CR is numeric (long) as shown in the snapshot.

RoadwayElevation is numeric (double).

 

0 Kudos
ABishop
Regular Contributor III

Are they shape files or feature classes?  If they are feature classes where are they being stored?  Database or file geodatabase?

Amanda Bishop, GISP
0 Kudos
LeilaJackson1
Occasional Contributor

Feature classes stored in a file geodatabase. I am using ArcGIS Pro 2.8.1.

ABishop
Regular Contributor III

Try adding an attribute index or global ID. 

Amanda Bishop, GISP
0 Kudos