ArcGIS Pro 2.9.0 Crushes when I try to import a map layout into an open project or export a layout from the previous version

3236
16
Jump to solution
11-15-2021 01:09 AM
MosesIranya_Otes
New Contributor

Hello. On upgrading to the new ArcGIS Pro 2.9.0, I noticed that the program crushes when ever I try to import an existing map layout file (.pagx) from the previous version into a project. When the file is opened directly from the file browser by double clicking, ArcGIS Pro 2.9.0 will run it without any issues and a new project is created. However, the program will crush when ever I try to export my completed map from this specific map layout. It won't crush if a new layout is created in this version though.

Is there any solution out there for this problem?

Thank you 

Moses

1 Solution

Accepted Solutions
TomBole
Esri Regular Contributor

Hi Moses, 

We are aware of a software crash when exporting of a layout that contains "null" text elements. 

Do you have any empty text elements in your layout? If so, I would recommend removing these elements from the layout, or entering an empty space into the element. 

Hope this helps,

Tom

View solution in original post

16 Replies
TomBole
Esri Regular Contributor

Hi Moses, 

We are aware of a software crash when exporting of a layout that contains "null" text elements. 

Do you have any empty text elements in your layout? If so, I would recommend removing these elements from the layout, or entering an empty space into the element. 

Hope this helps,

Tom

MosesIranya_Otes
New Contributor

Hello Tom,

I have lots of text elements in the layout. After critical examination of all of them, I noticed that indeed there was a text element that contained "null" (was empty) as you'd suspected. Inserting text into it fixed this problem.

 

Thank you

Moses

MikeRatcliffe
Occasional Contributor

This is indeed, not only a problem with export to .pdf.  It is a crash while printing, or previewing as well.  Guessing ESRI is already working 2.9.1.

TomBole
Esri Regular Contributor

Thanks for the additional info Mike.  And you're correct - we (Esri) are working on getting a solution to this issue out to the ArcGIS Pro 2.9 community.

rburke
by
Regular Contributor III

@TomBole  Thanks! I'm having the same issue. Took some fine combing to find the empty text, but that worked (and got me to organize my layers a bit better!).

0 Kudos
EugénioNgolaMalengue
New Contributor

Hi, Tom Bole,

That's great.
Does for KML should be the same case?

0 Kudos
TomBole
Esri Regular Contributor

Hi Eugénio, 

This particular crash is not specific to KML.

Please contact support. They are much better equipped to handle troubleshooting steps and gather bug data. It is extremely difficult to fix bugs that we cannot reproduce and, while good information can be found in these forums, and the feedback is very welcome - even when it is negative - this is not a substitute for our bug tracking system.

Support can be contacted at https://support.esri.com/en/contact-tech-support.

Thanks, 

Tom

0 Kudos
LindseySpears
New Contributor

Hi Tom, I am confused on how to find null text elements. I have just looked through and did not see any. Does this only apply to text elements that are checked? 

Thank you,

Lindsey

0 Kudos
LindseySpears
New Contributor

Tom, I did actually find the null text element and I got the layout to export. Thank you for your help!

0 Kudos