ArcGIS Pro 2.8 broke Jupyter Notebooks Functionality (Proxy_Host Error)

431
2
06-28-2021 08:57 PM
Labels (1)
AdamR
by
New Contributor II

After upgrading to ArcGIS Pro 2.8 our Jupyter notebook scripts handling content migration have broken.

They are no longer able to authenticate against our proxy and are reporting the following issue:

ConnectionError: A connection error has occurred: HTTPSConnectionPool(host='[DOMAIN].gov.au', port=443): Max retries exceeded with url: /portal/sharing/rest/info?f=json (Caused by ProxyError('Cannot connect to proxy.', OSError(0, 'Error')))

I feel the upgrade has broken some of the python code handling proxy_host.


Similar/same Issue @GIS_Unit_Kedron
https://community.esri.com/t5/arcgis-pro-questions/proxy-host-change-with-jupyter-notebooks-and-arcg...

2 Replies
AdamR
by
New Contributor II

Update: ESRI confirm it's a bug (BUG-000140337). Only solution is to roll-back Pro to 2.7 until a fix is provided. It might be related to BUG-000140216, which is covering the core Python API.

ArnoRöder
New Contributor

I have encountered the same problem. In my estimation, the bug is related to the newer versions of the urllib3-module. There, the proxy call must be made using the ProxyManager function. I escalated the bug because otherwise ArcGIS Pro version 2.8 won't work for us.