ArcGIS Pro 2.8 & spyder

1306
15
Jump to solution
09-07-2021 12:28 PM
ChadFerguson1
New Contributor II

I just installed ArcGIS Pro 2.8 and it appears that if I want to install spyder it is going to install v. 3.3.6.  This is archaic.  When I attempt this in conda it tells me if I do install, that it will downgrade both arcgispro and arcpy to 2.7  

 

How can I get a more modern version of spyder for ArcGIS Pro 2.8?? 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
JoeBorgione
MVP Esteemed Contributor

Are you at 2.8.0?  If so, that release had a bunch of problems with adding packages and clones.  Upgrade tp 2.8.2.  I used the conda install command on my 2.8.2 install.  I had installed 2.8 but backed it out when I ran into the problems.

That should just about do it....

View solution in original post

0 Kudos
15 Replies
JoeBorgione
MVP Esteemed Contributor

Open a python command prompt window in your cloned environment and do it with a conda command:

conda install spyder=5.0.4

 

That should just about do it....
0 Kudos
ChadFerguson1
New Contributor II

I tried that but got a laundry list of reasons why it's incompatible 

Of all the messages I received, this might help narrow it down??

Your python: esri/win-64::python==3.7.10=0

If python is on the left-most side of the chain, that's the version you've asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Note that conda will not
change your python version to a different minor version unless you explicitly specify
that.

0 Kudos
JoeBorgione
MVP Esteemed Contributor

Are you at 2.8.0?  If so, that release had a bunch of problems with adding packages and clones.  Upgrade tp 2.8.2.  I used the conda install command on my 2.8.2 install.  I had installed 2.8 but backed it out when I ran into the problems.

That should just about do it....
0 Kudos
DanPatterson
MVP Esteemed Contributor
conda install spyder=5.0.5 --no-pin

should work, or specify the "default" channel, in just change your .condarc file

you can switch the order of precedence if you like to live on the edge 

C:\your_install_folder\bin\Python

open in a text editor, it will look like this

channels:
- esri
- defaults

change to...

channels:
- defaults
- esri

I have been using spyder for years and yes, they need to remove the old version of spyder from their channel or keep pace with the times.


... sort of retired...
0 Kudos
ChadFerguson1
New Contributor II

Our organization only has version 2.8.0 certified for installation. As JoeB suggested there are known problems with that version I gave up and rolled back to 2.7.3.

So at least I am back up and running.

I squandered about a day and a half for nothing. Simply unbelievable.

Thanks for the suggestions and tips!

0 Kudos
AlexanderStum
New Contributor II

The above solution above doesn't seem to work for Pro versions 2.8 and 2.9. 

Anytime the approaches above are tried, --no-pin etc., it starts with this message:

"The environment is inconsistent, please check the package plan carefully
The following packages are causing the inconsistency:"

And ultimately fails to update spyder or spyder-kernels. I found a two-step work around that worked, though I recommend it only be applied to a cloned environment. First update all packages, and let conda discern what's the optimal set up.

conda upate -all

Yes this will ask you to downgrade arcpy to v. 2.7 as well as other attendant ESRI packages. This will make it incompatible with the installed version. The second step will amend this. Frankly this is a testament that ESRI has failed to put together a stable Python package for versions 2.8 and 2.9.... Now update arcpy by installing the correct version.

conda install arcpy=2.8 #or 2.9 per installed version

This will update arcpy and attendant ESRI packages, but will leave most other updates, including spyder, alone.

JoeBorgione
MVP Esteemed Contributor

The above solution above doesn't seem to work for Pro versions 2.8 ...

Well, I have Pro 2.8.2 installed and Spyder 5.0.5 installed in a cloned environment and things are working smoothly.  I'm two weeks out from retirement and plan to enjoy the time I have left, so I won't be upgrading to 2.9.0 anytime soon....

That should just about do it....
DanPatterson
MVP Esteemed Contributor

and I have Pro 2.9 and Spyder 5.15 installed in the main environment (no clone)

maybe in retirement things just go more smoothly 😉

 


... sort of retired...
PhilipWhite1
New Contributor III

This software just never fails to disappoint.

Same problem:  Fresh install of 2.9. Cloned environment, install spyder, wait, blow up.

 

 

 

(arcgispro-spy) C:\arc_pro\bin\Python\envs\arcgispro-spy>conda install spyder=5.1.5 --no-pin
Collecting package metadata (current_repodata.json): done
Solving environment: |
The environment is inconsistent, please check the package plan carefully
The following packages are causing the inconsistency:

  - esri/win-64::arcgis==1.9.1=py37_2327
  - esri/win-64::arcpy==2.9=py37_arcgispro_32704
  - esri/win-64::cftime==1.5.0=py37_1
  - esri/win-64::gdal==3.3.0=arcgispro_py37_16778
  - esri/win-64::h5py==2.10.0=py37_arcgispro_12
  - esri/noarch::lerc==2.2=py_0
  - esri/win-64::matplotlib==3.4.2=py37_arcgispro_1
  - defaults/win-64::mkl-service==2.3.0=py37h196d8e1_0
  - defaults/win-64::mkl_fft==1.3.0=py37h46781fe_0
  - esri/win-64::mkl_random==1.2.0=py37_0
  - esri/win-64::netcdf4==1.5.7=py37_arcgispro_2
  - defaults/win-64::numexpr==2.7.3=py37hcbcaa1e_0
  - esri/win-64::numpy==1.20.1=py37_0
  - defaults/win-64::pandas==1.2.3=py37hf11a4ad_0
  - esri/noarch::saspy==3.7.3=py_0
  - defaults/win-64::scipy==1.6.2=py37h14eb087_0
  - esri/win-64::swat==1.9.3=py37_0
  - defaults/noarch::xarray==0.17.0=pyhd3eb1b0_0

 

 

 After that just a littany of conflicts.

I actually thought I had this working on 2.8 somehow... arcpy would import fine then the kernel would crash anytime you tried to use it. I had hoped upgrading to 2.9 might remedy... ha!

0 Kudos