ArcGIS Pro 2.6.3 Definition Query

306
7
11-26-2020 06:33 AM
Labels (1)
Jurogin
New Contributor

Hi All,

I'm trying to make one basic Definition Query like "OBJECTID = 1" using one layer from one enterprise geodatabase (Oracle) and i'm receiving one error message "There was an error with the expression", but if I make the same query using the "Select By Attributes" the selection is done without problems.

So someone have ideas to solve my problem?

PS: Using the previous versions of ArcGIS Pro I was able to make query on the same layers. 

Thanks,

Vítor Carvalho

7 Replies
Robert_LeClair
Esri Frequent Contributor

Is the error occurring in the Layer Properties->Definition Query?  If so, click the SQL slider in the Layer Properties->Definition Query and type OBJECTID=1 without the quotes.  Click Apply followed by OK.  Does it process correctly?

KatharinaWerner1
New Contributor II

Hello, we've have the same problem.

We get this errormessage, when we use the SQL option. When we use the not-SQL option ArcGIS Pro crashes. But after some tries with not-SQL-option ArcGIS Pro crashes also. There isn't any systemic errorbehavior. I've created a case at Esri Support Germany. But we couldn't find the cause of the crash nor couldn't resolve the problem. I guess there's a bug in ArcGIS Pro. We'll see in the case, if there is a solution. 

Happy new year,

Kathi

 

 

Robert_LeClair
Esri Frequent Contributor

Kathi - interesting - thx for the response.  I wonder - have you upgraded to ArcGIS Pro 2.7 and attempt the same workflow again?  Not sure if it's a bug in ArcGIS Pro or not, but there were a lot of bugs resolved in the latest update.

KatharinaWerner1
New Contributor II
Hello Robert,

thanks for your answer. No we haven't already upgrated ArcGIS Pro. I'll try
the same workflow, when 2.7.x is released and let you know, if the problem
has resolved or not.






Robert_LeClair
Esri Frequent Contributor

Good morning - good news!  ArcGIS Pro 2.7 was released a little more than a week ago.  You can upgrade at any time and test the workflow again.  

KatharinaWerner1
New Contributor II

Hello Vitor and Robert, I could try the workflow with a newer Oracle-version (18c) in ArcGIS Pro. And Definition query works fine. So I guess, for me the problem is solved: newer version works fine. Probably Esri should check, if ArcGIS Pro 2.6.3 still supports Oracle-versions lower 12 (https://desktop.arcgis.com/de/system-requirements/latest/database-requirements-oracle.htm) 

Thanks for your help,

Kathi

Robert_LeClair
Esri Frequent Contributor

Kathi - based upon your attachment and the ArcGIS Pro Supported DBMS's (2.5, 2.6, 2.7), the only Oracle release lower than Oracle 12x is Oracle 11g R2 (64-bit) 11.2.0.4

In reviewing the details, Oracle 11g R2 (64-bit) 11.2.0.4 support goes all the way back to ArcGIS Pro 2.1

Anything other Oracle release is not supported and may be the culprit here.