Applying colour to portion of symbols in ArcPro

691
7
Jump to solution
01-31-2023 05:49 AM
Labels (1)
ChelseaP
New Contributor II

Is there a way to apply a colour ramp to a sub-section of symbols in Pro like there is in ArcMap?

ArcMap Link: How To: Apply a color range to a portion of symbols in ArcMap (esri.com)

 

0 Kudos
1 Solution

Accepted Solutions
Robert_LeClair
Esri Notable Contributor

Chelsea - this is BUG-000116248 - the color range applied to a portion of symbols in ArcGIS Pro is not honored.  It was seen in ArcGIS Pro 2.x and fixed at ArcGIS Pro 3.0.  If you upgrade to ArcGIS Pro 3.x, then you'll be able to do your workflow as demonstrated by Johannes.

View solution in original post

0 Kudos
7 Replies
JohannesLindner
MVP Frequent Contributor

Here we have a boring old random color scheme for our unique values:

JohannesLindner_0-1675174213178.png

 

When we select some unique values and change the color scheme, the new scheme only applies to the selected categories:

JohannesLindner_1-1675174295317.png

 

But it's still random. To make it a ramp, we have to change the scheme:

JohannesLindner_2-1675174394865.pngJohannesLindner_3-1675174470954.png

 

 

 

To learn more: Color schemes—ArcGIS Pro | Documentation


Have a great day!
Johannes
0 Kudos
ChelseaP
New Contributor II

That's very interesting. That's how I assumed it would work but it doesn't. When I select values the colour scheme changes for all the symbols. Maybe this is a bug? 

0 Kudos
jcarlson
MVP Esteemed Contributor

Are you making sure to select the specific classes you want changed? Adjusting the colour scheme without specific classes selected will change all of them.

- Josh Carlson
Kendall County GIS
0 Kudos
ChelseaP
New Contributor II

Yeah, I'm selecting classes first then changing the colour scheme but it still changes all of them. 

0 Kudos
jcarlson
MVP Esteemed Contributor

What version of Pro? It sounds like possibly Bug Territory, as @JohannesLindner 's steps work nicely over here (Pro 3.0.3).

- Josh Carlson
Kendall County GIS
0 Kudos
ChelseaP
New Contributor II

Hmm yeah might be. I'm 2.9.5

0 Kudos
Robert_LeClair
Esri Notable Contributor

Chelsea - this is BUG-000116248 - the color range applied to a portion of symbols in ArcGIS Pro is not honored.  It was seen in ArcGIS Pro 2.x and fixed at ArcGIS Pro 3.0.  If you upgrade to ArcGIS Pro 3.x, then you'll be able to do your workflow as demonstrated by Johannes.

0 Kudos