Adding X, Y data from standalone table

347
4
09-09-2021 02:10 PM
Labels (2)
kiwigrace1
New Contributor

Hello!

I am using ArcGIS Pro 2.6. I am trying to map coordinates from a standalone table I have (csv formatted), however every time I click 'Display XY Data' it creates a feature class but all of the long & lat values become either blank or 0, while all the other columns are kept the same. So nothing will show up on my map because the x,y data isn't there!

Please help me!

0 Kudos
4 Replies
David_Brooks
MVP Regular Contributor

Try using the XY Table to Point GP tool instead.

Or, if you just want to display XY and only have lat and lon, then change your map coordinate system to wgs84 before create the event layer


David
..Maps with no limits..
curtvprice
MVP Esteemed Contributor

It sounds like your xy data aren't getting loaded as type Double. You can see whether this the case by adding the table to a map, selecting the table in the Contents and selecting Feature Layer > Data in the ribbon. I'm guessing your lat long data is formatted incorrectly (Degrees Minutes Seconds), must be decimal degrees to plot on the map.

kiwigrace1
New Contributor

Ahhhh... I think you're right about the degrees, minutes, seconds thing.... I have quite a large dataset though, do you know an easy way to convert it to decimal degrees? I've looked online and it looks pretty labour intensive...... 

0 Kudos
curtvprice
MVP Esteemed Contributor
If you add the table to the map, copy it to the geodatabase and you may be able to use this tool to create decimal degrees.
Convert Coordinate Notation https://pro.arcgis.com/en/pro-app/latest/tool-reference/data-management/convert-coordinate-notation....