Enable the selection of Network Location to Add Folder Connection

3487
15
08-23-2018 02:16 AM
Status: Implemented
Labels (1)
SimonKettle
Regular Contributor

In Windows explorer you can Map a Network Drive (e.g. GIS Info (\\myserver\ggspatial\Folder) (Z:)) and also add a Network Location to Windows Explorer (a link direct to a folder in a network drive).

However, in ArcGIS Pro when I try to add a new folder connection to my project I cannot view my network locations (i.e. locations on the drive that are available with a folder icon in Windows Explorer)

Can ESRI add the functionality to ArcGIS Pro to recognise Network Folder Locations set up in Windows Explorer when adding a new folder connection to a project?

15 Comments
NajyaBatool1

Thanks for asking Simon, we have the same question!  Very frustrating.  

RonSantos

I've found a way to do this. From the Add Folder Connection screen, in the Name entry box at the bottom, type in the drive letter with backslash and a dot like this: 

z:\.

It would be easier to have a real means to do this though!

NaicongLi
Status changed to: In Product Plan
 
StefanThorn2

Hi @NaicongLi , nice that this will be implemented. When will this available in ArcGIS Pro?

KoryKramer

@StefanThorn2 This is planned for ArcGIS Pro 2.8 which is scheduled to be available sometime in May.

Hope this helps!

KoryKramer
Status changed to: Implemented

Implemented in ArcGIS Pro 2.8.

See Ideas in ArcGIS Pro 2.8 and (4:20) in the video.

MatthewClark

Has anyone had any luck with this?  My network mapped drives still do not show up in any Esri ArcGIS Pro file directories.

KoryKramer

Hi @MatthewClark when we saw your comment, a colleague of mine re-tested this in ArcGIS Pro 2.8 just to make sure we weren't missing something and did not see any problem adding a network location or a mapped network drive as a folder connection in Pro.

If this isn't working for you, you could either post a question in https://community.esri.com/t5/arcgis-pro-questions/bd-p/arcgis-pro-questions  to troubleshoot with other Esri Community members, or contact technical support to troubleshoot the issue.

Thank you!

BobDagg19

Hi

I have ArcGIS Pro 2.8.1. I am also trying to connect to a network share. I can see the folder in Add Folder Connection and it is showing up as connected. When I select the folder I get a Network Error message which says Connot Access Z:\

I tried the Z:\ trick above but that also did not work

Cheers

 

Bob

 

KoryKramer

@MatthewClark and @BobDagg19 It looks like there is a bug affecting some customers but to date there are no consistent steps that have allowed technical support to reproduce this issue.

Here is the bug number: BUG-000141160 

You may be encountering this bug but it would be important to work with technical support to confirm.  Here are the workarounds listed with the issue:

  • Drag and drop the item in question from Windows File Explorer to Catalog (folder connection).
  • Use a geoprocessing tool, and copy and paste the output location into the input text box, without using the file browser (Create File Geodatabase, Create Folder).

Do those work for you?