Can you easily set or change the default feature template in Traverse.

591
2
Jump to solution
05-03-2022 10:24 AM
Labels (1)
DeanAnderson2
Occasional Contributor II

Currently the traverse command appears to use the Default feature template.  I have not found a way to easily change this. Does one exist?  As a work around within the task environment, I have added a step before the traverse command and imbedded the "Assign Default to Field" tool.  Unfortunately, this tool does not recognize coded domains and only lets you select a value (see below).  The values below of 8,14,32 represent parcel boundaries, road right-of-ways, and railroad right-of-ways. 

DeanAnderson2_0-1651598477173.png

Please let me know if there is a better way to deal with this issue.   Thanks 

 

 

0 Kudos
1 Solution

Accepted Solutions
jcarlson
MVP Esteemed Contributor

When you are in a traverse, the line type is defined by your feature templates, which are available as a dropdown in the traverse window.

jcarlson_0-1651599047876.png

In order to set a default attribute, open up the properties of a given template, then navigate to the attributes tab of the template properties window.

jcarlson_1-1651599178958.png

You can also create a new template, and it will appear in the Traverse as well.

jcarlson_2-1651599281460.png

 

 

- Josh Carlson
Kendall County GIS

View solution in original post

2 Replies
jcarlson
MVP Esteemed Contributor

When you are in a traverse, the line type is defined by your feature templates, which are available as a dropdown in the traverse window.

jcarlson_0-1651599047876.png

In order to set a default attribute, open up the properties of a given template, then navigate to the attributes tab of the template properties window.

jcarlson_1-1651599178958.png

You can also create a new template, and it will appear in the Traverse as well.

jcarlson_2-1651599281460.png

 

 

- Josh Carlson
Kendall County GIS
DeanAnderson2
Occasional Contributor II

Thanks!  That is so funny.  I had not set up the templates for the parcel line feature class.  Its working fine now.