Unable to Update existing features using Append

401
1
12-02-2020 03:36 AM
DataOfficer
Regular Contributor

Despite following the guidance I have been unable to update existing features using Append data to layer from the Updata data button. I have tested this with multiple hosted feature layers, each with a unique ID field defined (see screenshot) . I have tried appending from csv, xlsx and zipped shapefiles but in all cases, the update existing features option is greyed out (see attached screenshot). The guidance suggests that the enable sync option has to be disabled, which it is. The fields also match exactly. Can anyone give ideas as to why I am unable to use this tool as intended? 

 

1 Reply
PRussell
New Contributor III

Did you ever find a solution for this?

We are experiencing the same issue with "Update Data" grayed out and only "Append data to layer" available.

Tried turning off all the Editing boxes (Enable editing, Keep track, Enable Sync) in Settings > Save, but that still doesn't change  the "Update Data" option being grey out.

0 Kudos