Unable to load addItem status: 504

583
4
05-29-2018 04:55 AM
DavidRalston
New Contributor II

I'm getting this error when trying to load a WMS layer to my arcgis online content

Tags (1)
0 Kudos
4 Replies
KellyGerrow
Esri Frequent Contributor

Can you share the WMS layer?

0 Kudos
DavidRalston
New Contributor II
0 Kudos
KellyGerrow
Esri Frequent Contributor

Do you need to add this as a wms service or can you use the map server endpoint?

https://cagmap.snh.gov.uk/arcgis/services/snh_renewables/MapServer

This url loads fine in map viewer, but we automatically use the map server url endpoint when it's available with ArcGIS Server based services which this is. You can add the WMS endpoint as an item using this url: 

https://cagmap.snh.gov.uk/arcgis/services/snh_renewables/MapServer/WMSServer

 I receive an error message, but the item loads just fine. I'll get the team to look into why an error is received, but as a best practice, I would recommend using the map server endpoint when its available.

-Kelly

0 Kudos
KellyGerrow
Esri Frequent Contributor

Hi David,

It looks like the thumbnail request is taking a long time to return which is causing a timeout issue (although the item eventually loads). I'd suggest looking into what is causing the issue when requesting the thumbnail through WMS but would recommend using the ArcGIS Server endpoint unless you are required to use the WMS endpoint.

http://cagmap.snh.gov.uk/arcgis/services/snh_renewables/MapServer/WMSServer?SERVICE=WMS&REQUEST=GetM... 

-Kelly

0 Kudos