Unable to Access Route URL

586
6
01-23-2019 05:05 AM
NDA-GISGhana
New Contributor III

Please I cannot access my route url when I am trying to add my directions widget in the webApp Builder. I need the solution very urgent. Below is the route url in the webApp builder: https://route.arcgis.com/arcgis/rest/services/World/Route/NAServer/Route_World 

Thank you.

Tags (3)
6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

The directions widget has the url https://route.arcgis.com/arcgis/rest/services/World/Route/NAServer/Route_World by default in the Route Url. Are you saying that it will not give you the green check next to the url in the widgets dialog? Or are you talking about trying to access the url rest end point in your browser? If you attempt to access the url in your browser it will not work as esri has the rest end point disabled for browsing.

0 Kudos
NDA-GISGhana
New Contributor III

Thank you Robert, I am talking about the widget in the web appBuilder, it

would show red instead of green. This is short of it. Thanks.

Sulemana Suale

RobertScheitlin__GISP
MVP Esteemed Contributor

What errors do you see in your browsers console?

0 Kudos
NDA-GISGhana
New Contributor III

The error below is shown in the console:

ArcGIS REST Framework

Home <https://route.arcgis.com/arcgis/rest/services>

*Error: *Services Directory has been disabled.

*Code: *403

On Wed, Jan 23, 2019 at 2:19 PM Robert Scheitlin, GISP <geonet@esri.com>

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

You should not see that error when using the widget. You would only see that error when trying to browse the url in your browser.

0 Kudos
AthenaAli
New Contributor

I'm having the same issues. Was this ever solved?

0 Kudos