Symbol layer drawing "Join" in AGOL

530
2
06-03-2022 02:38 AM
AdminWPZ
New Contributor III

Hi all,

ArcGIS Pro has this neat function "Enable symbol layer drawing" where you can define multi-level line symbols and set the Drawing Order to "Join" (all yellow line features are joined to look like one line)

AdminWPZ_0-1654248398544.png

vs. standard "No Join" (yellow line is interrupted with every single feature)

AdminWPZ_1-1654248464918.png

Sadly the "Join" setting is not transferred to AGOL when I publish the layer map. It seems not to exist in AGOL (or I just haven't found it?). Does anyone know of a workaround, e.g. via AGO Assistant? Or does the API simply not interpret this function? Here my JSON for reference:

AdminWPZ_2-1654248783763.png

Any hints are welcome.

Best,

Andrea

 

0 Kudos
2 Replies
Stefan_Thorn
Occasional Contributor II

Hi @AdminWPZ 

Have you tried to publish the webmap instead of the layer? As I remember, this will preserve setting but after you change the style it is converted to simple line style.

In ArcGIS Pro these are complex line styles while in AGOL these type of line style is not supported when 

The option to join is not available in AGOL.

AdminWPZ
New Contributor III

Hi Stefan

Thanks for the hint. Actually I did publish the map, not the layer (I wrote it wrongly in the original post). The line style is preserved in the new MapViewer, in the classic MapViewer it is not. I assume joins are not recognized / interpreted by the API.

0 Kudos