Swipe widget does not display list of all swipeable layers

184
1
Jump to solution
10-15-2020 12:28 PM
ScottMcGee4
New Contributor III

I added the Swipe widget to my ArcGIS Online web mapping application and configured the widget to display all the layers in the map. However, when I click on the Swipe widget, it does not show all of the layers in the pick list. Here are some screenshots:

The above screenshot shows all of the layers that I have turned on, or enabled, in the Swipe widget's configuration settings. The screenshot below shows the layers that are presented to the user.

I cannot figure out why the pick list (above) does not show a scrollable list of all the layers that I enabled in the configuration settings.

Any ideas why all the layers that I enabled in the configuration settings are not showing in the pick list?

0 Kudos
1 Solution

Accepted Solutions
ScottMcGee4
New Contributor III

Ok, well, I discovered that the Swipe widget is apparently smarter than I am. It turns out that in order for layers to be shown in the Swipe widget's pick list, they have to be turned on (enabled) in the Layers list. So by putting a check mark in front of a layer name in the Layers list, that will then make the layer show up in the Swipe widget's pick list.

View solution in original post

0 Kudos
1 Reply
ScottMcGee4
New Contributor III

Ok, well, I discovered that the Swipe widget is apparently smarter than I am. It turns out that in order for layers to be shown in the Swipe widget's pick list, they have to be turned on (enabled) in the Layers list. So by putting a check mark in front of a layer name in the Layers list, that will then make the layer show up in the Swipe widget's pick list.

View solution in original post

0 Kudos