Select to view content in your preferred language

Re-Value Coded Domain Values in ArcGIS Online Pop-ups

457
4
05-17-2023 02:58 PM
GarrettRSmith
Occasional Contributor II

Hello.

I am trying to see if it is possible to recode domain values within a pop-up?

This data is created via Survey123 and instead of the answers to the questions showing up, I am instead getting the coded domain values:

coded_domains.png

For example, in the image above, I would like "sites" to say "Emerging site".

Thanks for any help or guidance with this issue.

0 Kudos
4 Replies
MobiusSnake
MVP Regular Contributor

Any chance your S123 question is a "select_multiple"?  It's tough to create domains for those (and I don't think S123 even tries) because the number of permutations can be massive.

Otherwise, if you check your feature service, is there a coded value domain on it at that point?

0 Kudos
GarrettRSmith
Occasional Contributor II

Yes, this is a select multiple. It is not a huge deal if not. I can add a text field with an explanation for all the permutations. 

0 Kudos
MobiusSnake
MVP Regular Contributor

It's theoretically possible to set up the display values manually, but whether you want to bother probably depends how many combinations you've got.  You could possibly write some Python to update the field properties as well; I'm sure there must be a theoretical limit on the number of CV domain pairs on a field in AGOL however?

One thing I do for domain value readability sometimes is to use a longer value, for example in your case I might use "EMERGING_SITE" as a code rather than "sites".

Another alternative - if you've only got three or four options in your select_multiple - is to delete the field and replace it with three or four yes/no fields.  This gets ugly fast as you have more options however.

0 Kudos
GarrettRSmith
Occasional Contributor II

Thanks.

I use shorter domain values because I bring this data into R for some statistical analysis, and it is much easier to evaluate if the column values are simple. Though the multiple answer questions are awful to work with anyways.

I was unaware that ArcGIS Online would pull the coded domains and not the answer values. When I open the table in ArcGIS Pro the columns are filled with the actual answers. It seems like there is not an elegant solution to this.

0 Kudos