Problems editing data in a hosted view layer

87
0
10-25-2021 09:16 AM
Labels (1)
Trippetoe
Occasional Contributor III

Hello.

I'm seeing some weird behavior (outlined below) with a Hosted View Layer.  The source for the view layer is an AGOL Hosted feature layer that has attachments enabled and has three related tables as part of the service.  I am the owner of the hosted feature layer, and I have AGOL admin privileges. 

This behavior can be repeated. I create a view layer by clicking the Create View Layer button. I accept the default option to "Preserve Layer IDs".  After the view is created, I go to the 'Settings' for the item and select the checkboxes for Enable editing, Keep track of created and updated features and Enable Sync.

If I choose to 'Add to new map with full editing control', the View - including the three related tables - is added to a new map. 

  • I can edit the main/geometry layer by clicking the 'Edit' button in the main menu of the map or by clicking the Edit link in the popup dialog
  • I can open and edit data for all three related tables
  • Note that there doesn’t appear to be a way to ADD data to related tables; I can only update existing data

If I chose to 'Add to new map',  the View - including the three related tables - is added to a new map. 

  • I can NOT edit the main/geometry layer.  The Edit button in the main menu of the map is not present and the Edit link in the popup dialog is not present
  • I CAN edit two of the three related tables, but I can NOT edit the third related table

If I add the View to an existing map (that my account owns)

  • I can NOT edit the main/geometry layer.  The Edit button in the main menu of the map is not present and the Edit link in the popup dialog is not present
  • I CAN edit two of the three related tables, but I can NOT edit the third related table

Any thoughts on what's going on, and how i can edit data in a view

0 Kudos
0 Replies