Missing "Sign in" link

2025
6
Jump to solution
01-27-2017 02:54 PM
KeithSoRelle
New Contributor II

So I have installed Portal with the web adaptor and everything was running smoothly for a few weeks and then the "sign in" link on the home page is no longer there. I can access the sign on page through adding "signin.html" to the URL and am able to sign in. Can anyone think of a reason that this happened or how to fix it? Did I turn some setting on?

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
DanielUrbach
Occasional Contributor II

Hello Keith,

This behavior typically happens when you have Windows authentication enabled for either the portal webadaptor application or the website that it is configured on in IIS, without having the proper Windows authentication configured in Portal itself.

If you do want to use Windows authentication with your Portal, try configuring it using the following steps:

Use Integrated Windows Authentication with your portal—Portal for ArcGIS (10.6) | ArcGIS Enterprise 

If you are trying to simply use the built-in users in Portal, you will want to go to the IIS manager on the machine where the web adaptor is installed and disable Windows authentication for the web adaptor application.  Here is Microsoft's documentation on doing this:Windows Authentication | Microsoft Docs 

Note this doc shows how to enable it, just follow the same steps to disable it, but make sure to enable Anonymous authentication on the same window.

-Danny

View solution in original post

6 Replies
KeithSoRelle
New Contributor II

Portal 10.5 

0 Kudos
MarkNorbury
Esri Contributor

I also have this issue.  If I append the signin.html to the end of the URL I can sign in but then it signs me out again immediately and the sign-in link is still not there.

If I access Portal for ArcGIS via its port number (https://myserver.domain.local:7443/arcgis/home/), bypassing the web adaptor, then the sign-in link appears and I can login and use Portal as normal, but it would be good if I could use the web adaptor to access it.

0 Kudos
ArtieMcDonough
New Contributor

Is there a fix for this? I have a new installation of portal and some users of the portal do not see the sign in button?

0 Kudos
DanielUrbach
Occasional Contributor II

Artie,

See my explanation below on this, let me know if this works for you!

-Danny

0 Kudos
DanielUrbach
Occasional Contributor II

Hello Keith,

This behavior typically happens when you have Windows authentication enabled for either the portal webadaptor application or the website that it is configured on in IIS, without having the proper Windows authentication configured in Portal itself.

If you do want to use Windows authentication with your Portal, try configuring it using the following steps:

Use Integrated Windows Authentication with your portal—Portal for ArcGIS (10.6) | ArcGIS Enterprise 

If you are trying to simply use the built-in users in Portal, you will want to go to the IIS manager on the machine where the web adaptor is installed and disable Windows authentication for the web adaptor application.  Here is Microsoft's documentation on doing this:Windows Authentication | Microsoft Docs 

Note this doc shows how to enable it, just follow the same steps to disable it, but make sure to enable Anonymous authentication on the same window.

-Danny

View solution in original post

RyanMartin2
New Contributor III

Hi, this didn't work for me and I tried a number of things. Disabled IWA on the IIS adapter, anonymous only, restarted it. Restored the identity store back to the default built-in, restarted ArcGIS Portal. Changed the max token expiration to 2 weeks, restarted ArcGIS Portal. After all this, still no login box. Any ideas? I might add as above if it is accessed not through the web adapter, the Sign In box is there.

EDIT - So the above did fix it, it's just that Chrome wasn't clearing all the files with a Ctrl + F5. I had to clear all browsing history and then the sign in box came back

0 Kudos