Making a layer selectable in a web map

116
0
12-20-2021 08:28 PM
TuckerTeutsch
New Contributor

Hello Esri Community, this is my first post using this platform, so take it easy on me, but I will do my best to be detailed in my question!

I am wondering how you make a layer selectable in a web map using ArcGIS Online?

Here is my situation: For months I have been working on this project using ArcGIS Pro 2.9.0 and ArcGIS Online suite (specifically using web maps and dashboards). The main part of my project is a ArcGIS Online Dashboard, which is where my problem was found. Within the dashboard I have many widgets that work/filter with the web maps widgets that I have (please do refer to the png I attached and you will see what I am talking about). The widgets can either be filtered through using a list widget (bottom left corner) or by actually making a selection using the selection cursor tool in the top left corner of the web map widget. This is where my issue arises. Before making all of the layers associated with the dashboard and the web maps within shared to the public, I could make a selection within the web map widget using the selection cursor tool as I previously described. However, after I made all of those layers shared to the public to ready the dashboard project for a public launch, the selection cursor tool will no longer work. I can no longer use the selection cursor within the web map widget to make a selection in the layers that I have opened in that map, where I could do so before. Now when I try to use the selection cursor tool to click on one of my features within my layers that are showed within the web map widget it gives me a pop-up with a message saying "No feature available", when the features are clearly there, as you can see them and click on them without the selection cursor tool being used! After heavy troubleshooting and some advice from an ArcGIS elder I was advised that this must have something to do with the select-ability of the layers or the web map. But I just cannot figure this out, I did not deliberately change any settings related to this, and all the articles and advice I am getting online have only led me to dead-ends. 

I hope that someone on here can help me with this issue, thank you ahead of time for your time and energy.

0 Kudos
0 Replies