labels not showing in Map Viewer on AGO

1157
5
05-29-2019 11:13 AM
ErikBlake
Regular Contributor

we have 10.6 desktop. I have created callout text labels ( see image below) for our fleet locations. I published this mxd as a map and feature service to our GIS Server. When I add the map service or feature service to map viewer in AGO my labels don't show up. How do I get these to draw.

example of vehicle labels

0 Kudos
5 Replies
TylerBurns
New Contributor III

Hello Erik!

The issue you are describing is actually expected behavior. When publishing feature services, the labels do not automatically appear in the web map due to the fact that labels created in ArcGIS Desktop Clients (ArcMap/Pro) are actually part of the original map document's layer properties, and these properties are not carried over to the feature service during the publishing process.

It will be necessary to either create the labels for the features within the webmap viewer after adding the layer, or to create feature geometry from your labels by using the "Convert labels to annotation" and "feature outline masks" tools.

More information on these workflows can be found in the below article.

Problem: Unable to view labels on a hosted feature service published from ArcMap

https://support.esri.com/en/technical-article/000017863

Please note that while this article does reference hosted feature services published to ArcGIS Online, the knowledge is still applicable to feature services published to ArcGIS Server.

Regards,

TB

ErikBlake
Regular Contributor

Thanks Tyler.

0 Kudos
ErikBlake
Regular Contributor

Tyler

So I followed the steps in the guide, but when I save the labels as annotation to the Geodatabase, they disaapear from my mxd and the attribute table for the annotation layer is blank.Would you know why that is. Any help would be great. Thanks

0 Kudos
TylerBurns
New Contributor III

Hi Erik,

This may be an issue with the MXD or extent settings in the map. The following steps may be able to get you a bit further with this:

  1. Try selecting "Create Annotation For" -> "Features in Current Extent", instead of selecting "All Features". Make sure the current visible map extent includes all of your features.
  2. If 1 doesn't work: Open a Blank MXD -> bring in just the labeled layer -> create annotations.

Regards,

TB

0 Kudos
ErikBlake
Regular Contributor

Thanks Tyler. Much appreciated

0 Kudos