International Dateline on ArcGIS Online

926
8
05-11-2020 10:46 PM
AnareMOTOKULA
New Contributor II

I have been trying to upload a layer featuring pacific islands and it would seem like an easy step to simply add the layer to ArcGIS Online from ArcGIS Pro. Visually on ArcGIS Pro everything seems fine the projection for the layer is WGS 1984 PDC Mercator and I do not have any dateline issues. But once the layer is shared onto ArcGIS online that is where the dateline is introduced and I am assuming this is because the basemaps have a WGS 84 projection thus you have to view the 180 dateline. I was wondering if there was a way for the dateline to not show and this would also help when I create web applications on ArcGIS online so end users don't start to question the line going through the countries. There are 2 images attached to show the issue of once data is added online the international dateline is also added to the web map.

Thanks

Anare

0 Kudos
8 Replies
Peter_Klingman
Esri Regular Contributor

Thanks for the post Anare MOTOKULA‌ - have you tried this in Map Viewer Beta? Map Viewer Beta supports authoring maps in all coordinate systems as of April, so you will be able to save the map in WGS 1984 PDC Mercator. Here is a reference on the new functionality: https://community.esri.com/community/arcgis-online-map-viewer-beta/blog/2020/04/17/map-viewer-beta-u... 

Hope this helps,

-Peter 

0 Kudos
AnareMOTOKULA
New Contributor II

I had attempted to add the province layer in the beta version and it went well. The only issue was the fact the labelling it seems may have also been affected by the dateline. As you can see all labels show up on provinces left of the dateline but not province names to the right of the dateline which is 3 in total. That was the only reason I saw for the labels not showing for those provinces. If you have something new to try to ensure all labels show up. I would be happy to try. Thanks.Fiji Provinces

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi Anare MOTOKULA‌, thank you for the description and screenshot. Can you share your web map with PeterK_ess or publicly and link it here so I can take a closer look at the labeling issue? 

0 Kudos
AnareMOTOKULA
New Contributor II

Hi Peter,

Thanks for getting in touch. Because its just a single layer that I had added to the Map Viewer Beta and I cant seem to find a way to share the Beta Map Viewer so I was hoping to share the layer and for you to switch on the Province "Name" label to see the issue of labeling in the Beta version. So the layer to add is "Fiji_Admin2" from ArcGIS online.

Thanks again for the help.

Cheers

Anare

0 Kudos
Peter_Klingman
Esri Regular Contributor

Thank you Anare, this looks like a bug with Map Viewer Beta for features that cross the date line. I tested the issue with your layer and an in-house feature layer and I've reported it to the team. 

0 Kudos
AnareMOTOKULA
New Contributor II

Thanks Peter. And here close to the dateline we can always try and test the new beta versions as I think this location is a good place to see how well updates work. 

Appreciate you pointing this out to ESRI.

Cheers

Anare

JakeTarawa
New Contributor

Hi Peter,

Has there been any resolution to this bug? I am having the same issue with labels not appearing along the date line when creating a webmap for the Pacific.

Kind regards,

Jamie

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi Jake, the bug is currently being looked at for a future release but has not been resolved yet. 

Thank you,

-Peter 

0 Kudos