I'm trying to add a railroad service to my AGO Map but I keep getting an error. Any ideas? http://wwwgisp.rrc.state.tx.us/arcgis/rest/services/rrc_public/RRC_GIS_Viewer/MapServer

842
10
01-30-2017 11:56 AM
KarenLizano
New Contributor III

here is the service  rrc_public/RRC_GIS_Viewer (MapServer)  

Here is a link to the map where I think it is working http://wwwgisp.rrc.texas.gov/GISViewer2/  

I just want to put it in a web map?

0 Kudos
10 Replies
JonathanQuinn
Esri Frequent Contributor

Can you post a screenshot of the error?  Are you accessing AGOL over http or https?  It could be a mixed content issue, as I don't see any problems when I use http to access AGOL and use the http service URL:

On the other hand, if I use https to access AGOL and http for the service URL, that introduces an mixed content issue, as you can't mix http and https:

Some browsers allow you to ignore mixed content issues, but if you're accessing the webmap through https, try using http instead.  Unfortunately, if your organization is SSL only, that means you can only access the web map viewer over https, and the Server site hosting the service doesn't appear to have SSL enabled.

KarenLizano
New Contributor III

I am using https and i think that is the issue.  I noticed a couple of weeks ago I had to go in and change all of my map services to https in order to show up in my online ago map.  I bet this is the issue but I didn't change anything, that I know of, in the ago settings.  How can I go back to http??

0 Kudos
JonathanQuinn
Esri Frequent Contributor

Check if the Require SSL setting is checked, (I can't recall the exact wording of it), under your My Organization > Security settings:

Configure security settings—ArcGIS Online Help | ArcGIS 

If it's on, it may have been turned on for a reason, and turning it off may break existing webmaps if services in webmaps now go through HTTPS, and you access the webmaps over http.

KarenLizano
New Contributor III

Its off.  Was there an update in the last few weeks for AGO?  

0 Kudos
JonathanQuinn
Esri Frequent Contributor

Since it's off, can you access the web map viewer over http and add the service, (accessed via http as well)?  Any updates to AGOL wouldn't affect mixed content issues, if that's what this turns out to be.

0 Kudos
KarenLizano
New Contributor III

not if I login to AGO.  If I access the rest service via the rest directory and click open in arcgis.com Map, it does open it and I can see it but if I try to save and view it from my organizational account it gives me the error "unable to create a secure connection"??  

0 Kudos
JonathanQuinn
Esri Frequent Contributor

So if you were to sign in to your organization, and then go to the map viewer, ensure it's accessed over http, and then add the service accessed via http, you get the "Unable to create a secure connection" error?   What browser are you using?

0 Kudos
KarenLizano
New Contributor III

I'm using chrome.  Once I sign in, I cannot take off the "s"  it will re add it when I press enter, lol.  I'll try it in ie now too

0 Kudos
KarenLizano
New Contributor III

It does work in Fire fox!  YAY!  I guess there's is some setting in the chrome browser that only allows me to see secure sites when logged in to ago?  

0 Kudos