Select to view content in your preferred language

I have a feature class with PDF attachments. I need to post it on ArcGIS online as a hosted feature layer, but nothing I've tried so far seems to work

581
1
Jump to solution
09-29-2022 12:37 PM
Labels (1)
drewcole232
New Contributor III

1) I have successfully loaded the data into a test Feature Layer (hosted) in ArcGIS Online from a shapefile (see below). But shapefiles do not contain attachments - I need to load it with attachments. 

drewcole232_7-1664479661560.png

2) Kind of a side problem, but I haven't been able to zip up the folder containing my FGDB with attachments in windows explorer. I believe ArcGIS online requires the folder to be zipped. It's not a space issue. I have 200 GBs of free space. The FGDB with attachments is under 5GB. 

I have tried to append a FGDB of the original data (containing attachments) that was already zipped up in windows. It errors out; 

drewcole232_1-1664478148121.png

drewcole232_5-1664478872275.png

Any advice would be much appreciated. I attended to a conference recently and I believe I heard some advice to move away from hosted feature layers, but at this point, I am just trying to maintain and improve what we currently have before I move forward. 

 

 

 

 

 

 

 

0 Kudos
1 Solution

Accepted Solutions
drewcole232
New Contributor III

I was able to figure this out. I had to move my FGDB folder off of the server before zipping it up. There was some kind of lock on it while it was on the server. After zipping up the FGDB I was able to load it, with attachments included, to a new feature layer in AGOL. 

View solution in original post

0 Kudos
1 Reply
drewcole232
New Contributor III

I was able to figure this out. I had to move my FGDB folder off of the server before zipping it up. There was some kind of lock on it while it was on the server. After zipping up the FGDB I was able to load it, with attachments included, to a new feature layer in AGOL. 

0 Kudos