I do not want to show time with my dates, how can I remove it?

7419
11
Jump to solution
05-10-2016 08:17 AM
DonPritt
Occasional Contributor II

How can I remove the time in my dates? my date fields are showing the date with a "12:00 a.m." time in my online maps that I do not want. 

1 Solution

Accepted Solutions
ChrisWhitmore
Esri Regular Contributor

Hi Don - you can also hide the time part of the date field by configuring the pop-up to only show dates. In the Configure pop-ups panel on the layer menu, there's an option to configure attributes. There, you can change the field formatting for dates (and numbers). If you select your date field, you have the option to enable / disable 'Show time' for that particular field. Here's what you should see:

configuretime.jpg

Here's some info on how to configure popups:

Configure pop-ups—ArcGIS Online Help | ArcGIS

hope this helps -

Chris

View solution in original post

11 Replies
DanPatterson_Retired
MVP Esteemed Contributor

options here how do I change date format in labels  depending where and how you are getting your dates

ChrisWhitmore
Esri Regular Contributor

Hi Don - you can also hide the time part of the date field by configuring the pop-up to only show dates. In the Configure pop-ups panel on the layer menu, there's an option to configure attributes. There, you can change the field formatting for dates (and numbers). If you select your date field, you have the option to enable / disable 'Show time' for that particular field. Here's what you should see:

configuretime.jpg

Here's some info on how to configure popups:

Configure pop-ups—ArcGIS Online Help | ArcGIS

hope this helps -

Chris

DonPritt
Occasional Contributor II

Awesome Chris, what I was looking for.

0 Kudos
davidlam123
New Contributor

Thank you for the solution.

I have another issue. Even I did the method you provided. Also confirmed the change done. However, the time still in the date fields. 

The time still existing in the online map.

davidlam123_0-1646933244471.png

davidlam123_1-1646933260894.png

davidlam123_2-1646933289269.png

 

 

 

 

 

 

0 Kudos
KristinThorpe1
New Contributor III

Hi @davidlam123! I am having the same exact issue as you and it so frustrating! I have confirmed Show Time is unchecked in all layers and places (Hosted layer, View layer, Stakeholder Layer, Map Viewer, Data Visualization, etc.) and still no luck. The table in Map Viewer does not show time, but the Data table from the Item Details page and in the Table Widget in Experience Builder do show the time.

KristinThorpe1_0-1648652983535.png

 

Have you found a solution?

0 Kudos
SineKelly17
Esri Contributor

I am also experiencing this issue. I have configured the pop-ups on both parent and view layer so that the timestamp is not visible in the data.

However, I have a Smart Editor widget in a WebApp builder and the attribute form is still asking for a time input as well as a date. Is there any way to removed the time drop down? 

@ChrisWhitmore do you have any ideas?

0 Kudos
AlixVezina
Esri Regular Contributor

Hi @SineKelly17 , if the Time is disabled for a Date field in the pop-up configuration, the Time dropdown should not be shown in the Smart Editor's attribute form. If it is still displayed, it would be a bug.

I've done some testing on my end and I am not seeing issues with the Date/Time editing. Everything seems to reflect my field properties and the pop-up configuration settings I've assigned. Here's an example in ArcGIS Online Web AppBuilder:

AlixVezina_0-1658164607953.png

Is there anything specific about your field?

Are you in ArcGIS Online or using an older version of Web AppBuilder (ArcGIS Enterprise Portal / Developer Edition)?

 

 

0 Kudos
SineKelly17
Esri Contributor

Hi @AlixVezina thank you for responding 🙂

There a 3 different geometry layers which feed into the form. The time field for each layer was originally configured in the pop up, so the time entry was shown in the web app. But I have since updated the layers not to show time in the pop up, and the time entry is still there in the web app.

I don't think there is anything specific about the app, and I'm using ArcGIS Online. Is there anything else that could be an issue or do you think I should report a potential bug to tech support? 

0 Kudos
AlixVezina
Esri Regular Contributor

I went ahead and tried hiding the Time for my Date fields too, and it seems to be hidden as expected...

AlixVezina_0-1658251644167.png

Yes, at this point I think working with Technical Support would be most helpful so they can help find a potential workaround and reproduce the issue. Thank you for bringing up this issue @SineKelly17 !

0 Kudos