How to display no field heading text in the legend for an ArcGIS Online webmap

561
6
06-15-2021 08:20 PM
Labels (2)
GISCleanteq
New Contributor II

I dont want the field heading to display text in my legend for my webmap.
If I delete the text for the Field Heading under Fields on the right, the Field Name is used in the Legend.
Is there some code that will display a null value heading and not show anything in the legend?

AGOLFieldHeadingQuestion.png

0 Kudos
6 Replies
gisetc
by
New Contributor II

I discovered what I think might be a hack and probably not proper but works great for that. If you go into “Configure Popup” for that layer and even if you have done a custom popup go into “Configure Attributes” and delete the Field Alias in the popup definition. As I said, I am pretty sure this is not how it is intended to work but it works for me and I use it regularly for the education materials I am working on. Let me know if it works for you or if I wasn’t clear in my explanation. Two screenshots included.

0 Kudos
GISCleanteq
New Contributor II

Hi,
I tried looking for where I can remove the alias but I cant see the same area in 'Configure Popups' like you are.
I see you are using the classic viewer while I am on the new 'Map Viewer'
Does it look like I am in the right area (attached)?

0 Kudos
gisetc
by
New Contributor II

Hi, 

Yes, my hack is for Map Viewer Classic. You may be able to open your map in Classic, erase that heading in the Popup configuration and save the map. Then open the map up in the new Map Viewer and see if that configuration stuck. I’m 50/50 as to whether it will but it will take only moments to test. 

Sorry, I should have told you I found that work around in Classic. Best of luck and I hope it works for you!

Anita

0 Kudos
GISCleanteq
New Contributor II

Hi Anita,

Yes I switched back to Classic Map Viewer and found where you could edit the alias.
I removed the alias, then switched to the New Viewer and the alias was still there!

I guess the only resolution to this is publishing the web layer again from Pro without an alias.
Thanks for your input, I appreciate it

Cheers
Heath

 

0 Kudos
gisetc
by
New Contributor II

Well sorry Heath. I had hopes but figures they probably closed that work around I found. 

Best of luck,

Anita

0 Kudos
SimonSchütte_ct
Occasional Contributor
0 Kudos