How to add photos to existing Online Layer.

176
2
08-29-2021 09:34 PM
BECQ
by
New Contributor

Hello, 
I'm new to Arcgis Online and I feel like I'm taking crazy pills. I'm just trying to add photos to already existing points in a layer. Although I'm the creator of the layer I can't seem to add these photos. I've tried altering the attribute table in Arcpro as well as configure pop-up. When I click on a point and try to edit the pop-up it seems as though I can't add any photos. 

 

 

0 Kudos
2 Replies
PeterMacKenzie2
Occasional Contributor

Are you talking about adding attachments to an AGOL hosted feature layer within Pro?
What steps have you tried?

I'll take a guess - 

Here is a screenshot of the Add button. You get to this by right-clicking a row in the attribute table:

PeterMacKenzie2_0-1630301971580.png

Here  is a link about enabling attachments on a feature layer. 
Hope that helps. 

0 Kudos
David_Brooks
MVP Regular Contributor

@BECQ , a couple of troubleshoots:

1. have you enabled attachments in AGOL yet?

Brooks_SummitGeo_0-1630316802939.png

2. As @PeterMacKenzie2  said, you can assign attachments in the attribute table by RMC'ing. You can also open the Attributes panel from the Edit menu in Pro...

Brooks_SummitGeo_1-1630316921693.png

...and then add attachments there:

Brooks_SummitGeo_2-1630316980811.png

 

3. But if you're looking to do this in AGOL, you can add attachments via the Data tab from the Item Description menu:

Brooks_SummitGeo_3-1630317150767.png

 

4. Or if in a web map, you can edit features or add features and add attachments from the editing popup:

Brooks_SummitGeo_4-1630317301842.png

 


David
..Maps with no limits..