Hosted feature layer not opening in Map Viewer

653
3
01-19-2021 01:04 PM
RebeccaStobbe
New Contributor II

Hi!

I'm starting to do some mapping on ArcGIS Online for my thesis, and already running into trouble!! 

I created a hosted feature layer by uploading a .zip of in shapefile format, and the layer was created in My Content. But for some reason, it does not have the option to add this layer to Map Viewer to be mapped? I've done this before, and it had "Open in Map Viewer", "Create Presentation", etc as options in the hosted layer, but this new hosted layer only has the options: "Download", "Update", and "Share" (see photo).

Does anyone know what could be going wrong? I just got access to ArcGIS Online through my school, so maybe I don't have the access that I had before and it won't allow me to do hosted layers? Not sure, but any help is appreciated.

Thanks so much!!

Rebecca

0 Kudos
3 Replies
cartochien
Esri Contributor

Hi Rebecca,

When you add a shapefile to ArcGIS Online, it will host both the shapefile and the newly created hosted feature layer (if specified when you add the shapefile) in your ArcGIS Online Content. The screenshot you attached shows the item details for the "NY_natl_wetland_inventory" shapefile instead of the actual hosted feature layer which is why you're not seeing the options you would expect for a hosted feature layer. In your ArcGIS Online Content, be sure to click the "NY_natl_wetland_inventory" file that says hosted feature layer beside it and you will be able to see options such as "Open in Map Viewer" and so on.

Let me know if this helps!

0 Kudos
RebeccaStobbe
New Contributor II

Hey cartochien, 

Thank you so much for this response! This does make sense, however when I added the shapefile onto My Content, there was never an option to even make it a hosted layer. I tried following Esri directions I found online, so in My Content I chose "add item" and picked the zipped shapefiles, but there was never an option to "Leave the 'Publish this file as a hosted layer' box checked" as the instructions stated. So I guess that is why it is just a shapefile and not a hosted layer.... although I still don't know how to make it a hosted layer I guess haha.

For example, I'm attaching a pic of what it looks like when I'm uploading a different zipfile to My Content, and how it doesn't give me the option to make it a hosted layer.

I wonder if this is an access problem... it just seems like I don't have all the options & access on my account? 

0 Kudos
cartochien
Esri Contributor

Hi Rebecca,

Thanks for sharing the screenshot. I think you're right. It sounds like you have less privileges on your school's account compared to the account you used previously. Your account needs to at least have the Publisher role in order to publish hosted feature layers.