Filter by created_date not available anymore in Map Viewer Classic?

408
5
Jump to solution
04-22-2021 06:14 AM
AlinaT
by
New Contributor III

Is anybody else having issues creating a filter based on the created_date  or last_updated fields in Map Viewer Classic? I have a number of existing maps that are now broken because the filters don't work anymore. I noticed these two fields are no longer available in the pick list for a filter. 

0 Kudos
1 Solution

Accepted Solutions
Peter_Klingman
Esri Regular Contributor

Hi @AlinaT - thanks for sending the invite, I was able to test out the layer. It appears that it is not possible to filter by any date field on the service. I tested with Enterprise services coming from 10.8.1, 10.7.1 and 10.5 and was able to filter on a date field with all three. Was the service republished recently or did anything change on the database that the service originates from? Are you seeing this with other services or just this one? 

Is it possible the standardized SQL queries were disabled on your ArcGIS Enterprise Instance? 

Thanks,

-Peter

View solution in original post

5 Replies
Peter_Klingman
Esri Regular Contributor

Hi @AlinaT - I just tested this and I still see the created date field for my layer when filtering in Map Viewer Classic. Can you share the data to a group and invite PeterK_ess so I can take a look? 

0 Kudos
AlinaT
by
New Contributor III

Hi Peter,

I sent you an invite, please let me know if you don't get it. 

Thank you!

Peter_Klingman
Esri Regular Contributor

Hi @AlinaT - thanks for sending the invite, I was able to test out the layer. It appears that it is not possible to filter by any date field on the service. I tested with Enterprise services coming from 10.8.1, 10.7.1 and 10.5 and was able to filter on a date field with all three. Was the service republished recently or did anything change on the database that the service originates from? Are you seeing this with other services or just this one? 

Is it possible the standardized SQL queries were disabled on your ArcGIS Enterprise Instance? 

Thanks,

-Peter

View solution in original post

AlinaT
by
New Contributor III

Hi Peter,

You solved it! The standardized SQL queries were turned off last week while an ESRI tech tried to help me troubleshoot what I though was a potential SQL injection. I just reversed that setting and now I can see the created_date and last_updated_date.

Thank you very much for your help!

Peter_Klingman
Esri Regular Contributor

Happy to help out, glad it's resolved!

0 Kudos