Select to view content in your preferred language

Fields not showing up in Smart Editor (WebApp)

945
5
03-23-2022 03:38 AM
JasonCyphers
Occasional Contributor III

I created a web app with a Smart Editor widget.  I have two text fields that are not showing up in the smart editor, even though they're selected to be editable (Report Editor and Report Edit Details in the image below).

Any ideas?

JasonCyphers_0-1648031865375.png

5 Replies
AlixVezina
Esri Regular Contributor

@JasonCyphers Thank you for your post. I have a few questions :

Were these fields added to the layer after it was originally published?

How were these fields created?

Also, when was this web app originally created and the Smart Editor added?

 

0 Kudos
JasonCyphers
Occasional Contributor III

Yes, the fields were added after the hosted feature had already been created.

Fields were created through the feature's data tab > Fields > Add Field

The app (and smart editor widget) were created prior to the new fields being added to the feature.  I've since tried deleting the smart editor, saving the edits to the webapp, refreshing the webapp - adding a new smart editor widget, ensuring the two fields are selected as viewable & editable, but they still do not display in the smart editor.

0 Kudos
AlixVezina
Esri Regular Contributor

Would you be able to share your app, map and layer through a Group in ArcGIS Online so we can take a closer look? My username is AlixSolutions.

0 Kudos
JasonCyphers
Occasional Contributor III

I ended up deleting the map and webapp, rebuilt everything, and the two fields show up in the smart editor.

Thanks for the assistance though!

0 Kudos
HMarcks
New Contributor III

FYI I know you already figured this out by recreating it but I was having the exact same problem and finally figured out how to fix it.  Thought I might add it here in case anyone else had the same problem.

If you go to the map tab and click the drop down for Choose Web Map then choose Edit This Map it will open up map viewer of the map.  You then need to choose the layer and configure the pop up.  Choose configure Attributes and a table will come up with all the fields including those that were added after the WebApp was created, those ones have the display unchecked.  Check all the ones you want displayed, save it and close it.  They will now show up in the attribute widget.