Feature Layer (hosted, view) new field creation

196
4
Jump to solution
09-30-2022 12:51 PM
Labels (2)
drWood
by
New Contributor III

Hello all,

Recently one of our online services required a new field to be added to one of our feature services for display within a dashboard utilized by the public. I added the new field to be displayed within the hosted feature layer and populated the new field with the necessary data. 

When accessing the hosted view layer for this hosted layer the new field does not appear in the table at all. The new field still shows in the hosted feature layer in webmaps that have the hosted feature layer in it, but is not visible in any other views.

I was under the assumption that all edits should carry over to the other views. Any ideas on what is going on and how to address it? Thank you in advance!

 

-Derek Wood

0 Kudos
1 Solution

Accepted Solutions
Alfred_Baldenweck
New Contributor II

To your final point, all edits do carry over to the other views, but if they aren't relevant (e.g. filtered out via definition query, or those field weren't included) they won't show up.

That being said, I figured it out.

On the View, go to Settings, then Update View. You should be able to change the fields there.

AlfredBaldenweck_BLM_0-1664804801822.png

 

View solution in original post

4 Replies
EduardoDiaz
New Contributor II

Did you update the layer using Pro? (Append Tool) or how you update the data? https://support.esri.com/en/technical-article/000020494 

My first tought is the webmap who is used in dashboard´s is not the same who have the layer that you refresh.

0 Kudos
drWood
by
New Contributor III

The new field was added to the hosted feature and populated with data directly in AGOL. All of the updates to the data are done within the hosted layers and typically displayed within the hosted views automatically. For some reason the creation of a new field is not carrying over to the hosted views though.

0 Kudos
Alfred_Baldenweck
New Contributor II

To your final point, all edits do carry over to the other views, but if they aren't relevant (e.g. filtered out via definition query, or those field weren't included) they won't show up.

That being said, I figured it out.

On the View, go to Settings, then Update View. You should be able to change the fields there.

AlfredBaldenweck_BLM_0-1664804801822.png

 

drWood
by
New Contributor III

Thank you for tracking down the source of my problem! I was unaware of the need to update the views through the details page.

0 Kudos