error when adding a layer from the web

462
6
06-30-2014 07:23 AM
TAMARADIEZ
New Contributor III
Hi,

I am new with AGOL. I am trying to create a web map adding a hosted map service. Our ArcGIS Server is version 10.0.
I click on add layer from the web and then select "An ArcGIS Server web service" and enter the URL. The URL I am entering follow the structure http://servername/ArcGIS/rest/services/foldername/mapservicename/MapServer


I am receiving the following error:


"Error

The layer, layername cannot be added to the map"

Thanks,

T
Tags (2)
0 Kudos
6 Replies
MikeMinami
Esri Notable Contributor
Is your service behind a firewall or secured, requiring a username and password?

Thanks,

Mike
0 Kudos
TAMARADIEZ
New Contributor III
Hi,

I am new with AGOL. I am trying to create a web map adding a hosted map service. Our ArcGIS Server is version 10.0.
I click on add layer from the web and then select "An ArcGIS Server web service" and enter the URL. The URL I am entering follow the structure http://servername/ArcGIS/rest/services/foldername/mapservicename/MapServer


I am receiving the following error:


"Error

The layer, layername cannot be added to the map"

Thanks,

T


Hi Mike,

The ArcGIS Server is behind the firewall.

Thanks,

T
0 Kudos
MikeMinami
Esri Notable Contributor
If your computer is also behind the firewall, then you should be able to draw the layer. However, because it's behind a firewall, some actions of ArcGIS Online, like editing, won't work. For some operations, the service needs to be accessible from the web. You say you're running Server 10.0. Do you have any service packs installed? I think at SP1, Server supports CORs, which did allow editing behind a firewall.

Thanks,

Mike
0 Kudos
TAMARADIEZ
New Contributor III
I have installed ArcGIS Server for the Microsoft .NET framework 10 - GIS Services Service Pack 4.


I have tried it again and after I entered the map service URL I received a Security Warning message: "Do you want to view only the web page that was delivered securetely? This webpage contains content that will not be delivered using a secure HTTPS connection which could compromise the security of the entire website�?�. I was clicking on Yes before and therefore I was receiving the error.  If I click on No, it works but I am concerned about this security message.  Do I have to worry about it?

Many thanks,

T
0 Kudos
MikeMinami
Esri Notable Contributor
I assume you have an organizational subscription configured with SSL enabled (HTTPS). When a website is requires SSL, the browser may block or warn you when you accessing non SSL content. Ideally, your ArcGIS Server should also be SSL enabled, if you truly need this level of security. Do you need SSL on your organizational subscription?

Thanks,

Mike
0 Kudos
TAMARADIEZ
New Contributor III
I assume you have an organizational subscription configured with SSL enabled (HTTPS). When a website is requires SSL, the browser may block or warn you when you accessing non SSL content. Ideally, your ArcGIS Server should also be SSL enabled, if you truly need this level of security. Do you need SSL on your organizational subscription?

Thanks,

Mike


Hi,
I checked the security within the ArcGIS Online and the SSL was enabled. I have now disable it.

I don't know if we need SSL on our organisational subscription as I do not understand about this too much.

Thanks,

T
0 Kudos