Creating Labels in AGOL Map Viewer Beta

212
5
04-07-2021 03:17 PM
Labels (2)
JoeBorgione
MVP Esteemed Contributor

I've been attending the developers summit this week, and sitting in Arcade sessions when I can.  I'm messing around with the Map Viewer Beta which as I understand it, will no longer be beta next week.

The label/Arcade Editior makes it pretty easy to create a label, but it's  a little weird at the same time.

In the list of globals, some of the field names are in brackets and quotes and yet others are not:

JoeBorgione_0-1617833454197.png

So when I select them, my expression looks like this:

JoeBorgione_1-1617833491094.png

 

And it's flakey: it tests okay, but sometimes I get labels and sometimes not.

Has this bun been in the oven long enough to come out of beta?

can't wait to retire....
0 Kudos
5 Replies
jcarlson
MVP Regular Contributor

Can you give a few examples of when it works and when not? I personally love labeling in the new Map Viewer. I haven't run into any problems myself.

The attribute naming is related to Dot vs Bracket Notation.

- Josh Carlson
Kendall County GIS
JoeBorgione
MVP Esteemed Contributor

Well now it’s working now so I’ll have to wait till it stops working to show you. Another colleague was getting the same behavior but yet for another it worked fine. 

Naturally it worked great in the session demos today so I was stoked to give it a try. 

can't wait to retire....
jcarlson
MVP Regular Contributor

That's the way it tends to go! You have to wonder what kind of specs are on the demo machines sometimes.

- Josh Carlson
Kendall County GIS
0 Kudos
DanPatterson
MVP Honored Contributor

They probably working with locally stored data 😉 leaves out the sde/network bog


... sort of retired...
0 Kudos
JoeBorgione
MVP Esteemed Contributor

I don't have the luxury of having the man behind the curtain so as a rule I don't do live demos, especially in ZoomLand....  

can't wait to retire....
0 Kudos