Cannot add map as target of selector in ArcGIS Online Dashboard

205
7
12-27-2021 10:31 AM
KristieReece
New Contributor III

In the process of creating a dashboard in ArcGIS Online. I have added selectors to the dashboard that succesfully filter all of the charts; however, I cannot add the map as a target of the selector. How do I use these selectors to filter the map as well?

0 Kudos
7 Replies
jcarlson
MVP Honored Contributor

You should be able to filter individual layers from the map. When adding a target to the selector's filter action, just look for the map, and then select an individual layer from within the map.

jcarlson_0-1640631635040.png

Do you just not see any map layers as available targets? Can you provide a screenshot of what you're seeing?

- Josh Carlson
Kendall County GIS
0 Kudos
KristieReece
New Contributor III

Hi Josh,

I'm not seeing the map displayed under the Add Target drop down.

 

KristieReece_0-1640632199937.png

0 Kudos
jcarlson
MVP Honored Contributor

Strange! Is the same data being pulled into the various charts?

Also, is the map data coming from a Feature Service or a Map Image Service? The latter may support data access for charts, but will not support spatial operations in the map, and I've had trouble getting Map Image layers to "play nice" with Dashboards.

- Josh Carlson
Kendall County GIS
0 Kudos
KristieReece
New Contributor III

Yes, the charts and the map are all reading the same Feature Layer (hosted). I did create all of the charts prior to creating the web map and adding it into the dashboard though. Could that be the issue?

Is there a setting on the Feature Layer itself that needs to be enabled? I wouldn't think so seeing that I can add the same map to a web app and create filters within it that work fine. Just cannot seem to manage it within the dashboard.

0 Kudos
jcarlson
MVP Honored Contributor

Your selector is pointed at the layer itself, not the map's layer? It really shouldn't matter, as I'm able to have a selector act against any other layer in the dashboard, map or not.

Try recreating the selector, but choose the map layer as the source layer for its values.

- Josh Carlson
Kendall County GIS
0 Kudos
KristieReece
New Contributor III

When choosing the layer for the selector, it states "The map doesn't contain layers that can be used." But it does show the desire layer under the "Stand-alone layers' section. Looks like I may need to check some settings, but I do feel like I'm making progress! Thank you!

0 Kudos
jcarlson
MVP Honored Contributor

Double check how the map is configured. Maybe it's got something to do with layer order or grouping?

You might try re-adding the layers to your map from their URL, as in "...rest/services/.../FeatuerService/0". In cases when I've had issues with services and dashboards working together, I usually have better luck when the layer's added by its specific layer URL, rather than adding the whole service all at once.

- Josh Carlson
Kendall County GIS
0 Kudos