Cannot add an ArcGIS Service from Portal to ArcOnline Anymore

704
7
07-02-2021 09:19 AM
JesSkillman
New Contributor III

I'm trying to share a feature service from our ArcGIS Portal to ArcOnline. The feature service is shared to everyone on Portal. Previously, we just used the "Add an Item" tool (this tool still on our Portal) and everything worked just fine. Apparently today the "Add an Item" tool has been updated, but it doesn't seem to work. My issues:

1) What is a custom parameter and why is it important?

2) Am I doing something wrong or is this a bug? 

3) Can you please provide more documentation for this new item tool?previous_system.pngnew_system.png

Tags (3)
7 Replies
jcarlson
MVP Notable Contributor

I can confirm that I see this error as well, connecting to other services. And it does appear to be an issue with the new tool.

For now, you can still add layers from a URL in the map viewer itself, then save it as a content item from there.

jcarlson_0-1625246455241.png

 

- Josh Carlson
Kendall County GIS
0 Kudos
JesSkillman
New Contributor III

Thank you Josh. I'll try that.

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi @JesSkillman and @jcarlson - I am able to reproduce the issue with services from this Enterprise deployment but not others (SampleServer6, an in-house 10.9 federated environment). It looks like the tool tries to find /MapServer, which is a nonexistent endpoint for hosted feature layers, then fails. I'm going to report this to our Development teams, it looks like a bug to me. Please let me know and I can create a support case for you so we can track this more closely and investigate further as needed. Thanks!

SolanaFoo2
New Contributor III

I've also just reported another bug when adding stand-alone ArcGIS Server feature services (not federated) with authentication saved in them, in the new AGOL interface upgrade.  Tech support was able to reproduce my error.  I'll post separately from this as well.  They said they would get back to me once they have a hot fix.

0 Kudos
JesSkillman
New Contributor III

Hi Peter,

Sorry for the delay in response. Yes, please create a support case for me. Thank you for looking into this.

 

Best

Jes

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi @JesSkillman,

I created a case for you and an analyst will be reaching out as soon as possible. I take it that you are still running into the issue?

Thanks,

-Peter 

0 Kudos
JesSkillman
New Contributor III

Hi Peter,

That's correct. Thank you for creating a case. Someone has reached out. 

 

Best

Jes