Cannot add a user outside the Org if their username starts the same as local Org account

212
4
04-09-2019 03:03 PM
DougBrowning
MVP Notable Contributor

I have found that it is impossible to add a user outside my Org if that user has a similar starting pattern to their username in both Orgs.

Example:

Org1 is a parent company to Org2

Org1 user name is joe_X_Y

Org2 user name is joe_X

Try to invite user joe_X to a group in Org1 and it will never find joe_X.  It will only ever show joe_X_Y.  Even when I uncheck Search Only in the Org button and am searching on joe_X.

If joe_X_Y is a Group Manager then it will skip joe_X_Y and find joe_X no problem.  But only in this case.

This puts us at a dead stop in our project.  There is no way to add a user in Org2 ever!  Seems like a bug where the search is just stopping on a find instead of searching for ALL cases.

Any ideas?  Is this going to be fixed?

Only ideas is to change the group manager each time, or change all our account to say joe2_X.  But that is a HUGE project.

thanks

0 Kudos
4 Replies
rachelg_esri
Esri Contributor

Hello Doug!

Definitely sounds like some strange behavior. So that I understand your scenario, can you confirm if this is correct?

Organization A                           Organization B

User_A                                          User_AB

OrgAGroup

GroupOwnerUser

So, GroupOwnerUser tries to invite UserAB to OrgAGroup, is that right? Does GroupOwnerUser have to be User_A or it can be anyone?

I'll do some testing and see if I can reproduce the issue here. If I can, we'll get a bug logged for you and see if we can find any workarounds.

Thanks for your patience and clarifications!

Best regards,

Rachel

Esri Support Services

Rachel Guttmacher
ArcGIS Online Technology Lead
Esri Support Services
0 Kudos
DougBrowning
MVP Notable Contributor

So, GroupOwnerUser tries to invite User_AB to OrgAGroup, is that right?  

    - Correct

Does GroupOwnerUser have to be User_A or it can be anyone?

   - If GroupOwnerUser is User_A then it will skip User_A and find User_AB no problem.  

   - If GroupOwnerUser is NOT User_A then User_AB will never be found.

Note in my org it is just how I wrote it with the _ so test that also.  AKA user_A and user_A_B.  This may cause a difference.

Thanks!

rachelg_esri
Esri Contributor

Hello Doug!

Sorry for the delay on this. I was able to test the behavior and confirmed similar issues on my end. I've went ahead and logged the following bug:

[BUG-000121718: Searching for members to add to a group doesn't always find all users when similar usernames exist.]

If you'd like you can call Esri Support Services to have a case created, which we can then attach to this bug. This will allow you to track the bug status in My Esri and escalate the bug if needed.

We'll have to wait on Development to take a look at this and see what they can do, but for now we've made them aware by logging the bug.

Thank you for bringing this to our attention!

Best regards,

Rachel

Esri Support Services

Rachel Guttmacher
ArcGIS Online Technology Lead
Esri Support Services
0 Kudos
DougBrowning
MVP Notable Contributor

I worked with the admins some more and we may have a workaround.  Posting in case it helps someone.

If we make the Profile of the user that is not being found Public - then it does find them.  We do not allow public normally but the admins are willing to make it public, add to group, turn public back off to get around the bug for now.

We think we could also change owner each time but not tested.

Thanks

0 Kudos